This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Riffaz 1 year ago.

Assigned support staff: Riffaz.

Author Posts
October 1, 2018 at 8:48 pm

Sergio

Hello, please go to hidden link
As you can see if you put the cursor on the language name the following appears:

<img class="wpml-ls-flag" src="<em><u>hidden link</u></em>" alt="nl" title="Nederlands">

I saw this thread:
https://wpml.org/forums/topic/hovering-language-switcher-it-shows-full-path-of-source-code-of-html/

However it' strange, because:
-this is a supported wpml theme
-the same configuration is in this site hidden link and the issue doesn't appear.

Is there a solution, not a workaround?

October 2, 2018 at 8:12 am #2780652

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi Sergio,

The alt tags are controlled by your theme's JavaScript.

The alt tag for your language switcher is "nl". with their titles: hidden link

It seems that your theme is picking up the whole code as the anchor tag title.
If you examine your front-end code you will notice that the title is wrongly wrapped. (Please check the attached screenshot)

You can test that this is theme related by switching to a default theme such as twenty17 and examining the flags with it as well.

Standard code for language flag in my local environment

<a><img class="wpml-ls-flag" src="<em><u>hidden link</u></em>" alt="ar" title="العربية"></a>

The way your theme displays the flags

<a nederlands="" title="<img class="wpml-ls-flag" src="<em><u>hidden link</u></em>" alt="nl" title="Nederlands"><span class="wpml-ls-native">Nederlands</span>" href="<em><u>hidden link</u></em>">
<img class="wpml-ls-flag" src="<em><u>hidden link</u></em>" alt="nl" title="Nederlands"><span class="wpml-ls-native">Nederlands</span>
</a>

Essentially the problem is the following part of the HTML code

<a title="

It needs to be just

<a><img class = " ....

Please contact your theme support.
They will be able to fix this in minutes.

Regards,
Riffaz.