This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Andreas W. 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
October 2, 2019 at 1:04 pm #4680351

samvelA

Tell us what you are trying to do?
The WPML stopped working properly. Content in two different languages appears on the same page. The WPML is not customizable (widgets, etc), when Elementor plugin is activated. The WPML becomes customizable when Elementor is inactive, however once you make customization and then reactivate WPML it ceases working again.

Here is the message we get when try to customize WPML widget
https://www.armenianschool.ca/wp-admin/admin.php?wpml-ls-refresh-on-browser-back-button=no&languages_order%5B%5D=en&languages_order%5B%5D=hy&link_empty=0&copy_parameters=&additional_css=&migrated=0&wpml_ls_available_sidebars=default-sidebar&sidebars%5Bdefault-sidebar%5D%5Btemplate%5D=wpml-legacy-horizontal-list&sidebars%5Bdefault-sidebar%5D%5Bdisplay_names_in_native_lang%5D=1&sidebars%5Bdefault-sidebar%5D%5Bdisplay_link_for_current_lang%5D=1&sidebars%5Bdefault-sidebar%5D%5Bwidget_title%5D=&wpml-ls-in-sidebars-default-sidebar-colorpicker-preset=&sidebars%5Bdefault-sidebar%5D%5Bbackground_normal%5D=&sidebars%5Bdefault-sidebar%5D%5Bborder_normal%5D=&sidebars%5Bdefault-sidebar%5D%5Bfont_current_normal%5D=&sidebars%5Bdefault-sidebar%5D%5Bfont_current_hover%5D=&sidebars%5Bdefault-sidebar%5D%5Bbackground_current_normal%5D=&sidebars%5Bdefault-sidebar%5D%5Bbackground_current_hover%5D=&sidebars%5Bdefault-sidebar%5D%5Bfont_other_normal%5D=&sidebars%5Bdefault-sidebar%5D%5Bfont_other_hover%5D=&sidebars%5Bdefault-sidebar%5D%5Bbackground_other_normal%5D=&sidebars%5Bdefault-sidebar%5D%5Bbackground_other_hover%5D=&statics%5Bfooter%5D%5Btemplate%5D=wpml-legacy-horizontal-list&statics%5Bfooter%5D%5Bdisplay_flags%5D=1&statics%5Bfooter%5D%5Bdisplay_names_in_native_lang%5D=1&statics%5Bfooter%5D%5Bdisplay_names_in_current_lang%5D=1&statics%5Bfooter%5D%5Bdisplay_link_for_current_lang%5D=1&wpml-ls-static-footer-colorpicker-preset=&statics%5Bfooter%5D%5Bbackground_normal%5D=&statics%5Bfooter%5D%5Bborder_normal%5D=&statics%5Bfooter%5D%5Bfont_current_normal%5D=%23444444&statics%5Bfooter%5D%5Bfont_current_hover%5D=%23000000&statics%5Bfooter%5D%5Bbackground_current_normal%5D=%23ffffff&statics%5Bfooter%5D%5Bbackground_current_hover%5D=%23eeeeee&statics%5Bfooter%5D%5Bfont_other_normal%5D=%23444444&statics%5Bfooter%5D%5Bfont_other_hover%5D=%23000000&statics%5Bfooter%5D%5Bbackground_other_normal%5D=%23ffffff&statics%5Bfooter%5D%5Bbackground_other_hover%5D=%23eeeeee&statics%5Bpost_translations%5D%5Btemplate%5D=wpml-legacy-post-translations&statics%5Bpost_translations%5D%5Bdisplay_names_in_native_lang%5D=1&statics%5Bpost_translations%5D%5Bdisplay_names_in_current_lang%5D=1&statics%5Bpost_translations%5D%5Bdisplay_before_content%5D=1&statics%5Bpost_translations%5D%5Bavailability_text%5D=This+post+is+also+available+in%3A+%25s&statics%5Bshortcode_actions%5D%5Btemplate%5D=wpml-legacy-horizontal-list&statics%5Bshortcode_actions%5D%5Bdisplay_names_in_native_lang%5D=1&statics%5Bshortcode_actions%5D%5Bdisplay_names_in_current_lang%5D=1&statics%5Bshortcode_actions%5D%5Bdisplay_link_for_current_lang%5D=1&wpml-ls-in-shortcode-actions-colorpicker-preset=&statics%5Bshortcode_actions%5D%5Bbackground_normal%5D=&statics%5Bshortcode_actions%5D%5Bborder_normal%5D=&statics%5Bshortcode_actions%5D%5Bfont_current_normal%5D=&statics%5Bshortcode_actions%5D%5Bfont_current_hover%5D=&statics%5Bshortcode_actions%5D%5Bbackground_current_normal%5D=&statics%5Bshortcode_actions%5D%5Bbackground_current_hover%5D=&statics%5Bshortcode_actions%5D%5Bfont_other_normal%5D=&statics%5Bshortcode_actions%5D%5Bfont_other_hover%5D=&statics%5Bshortcode_actions%5D%5Bbackground_other_normal%5D=&statics%5Bshortcode_actions%5D%5Bbackground_other_hover%5D=#

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?

October 2, 2019 at 9:40 pm #4683355

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Before taking any further steps, please increase your WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 512M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and no other plugins installed.

If this will not solve the issue, it might be that we are handling a compatibility issue which might even be caused by another third plugin.

Disable any additional plugin that is not Elementor or related to WPML and its add-ons.

If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Let me know about the outcome.

Kind regards
Andreas

October 3, 2019 at 9:32 pm #4691551

samvelA

Hi, we increased the memory limit to 256 but the issue still persists.

I do not think it is because of the theme/plugin, because it used to worked properly with the same themes and plugins.

FYI, when Elementor is desactivated, WPML starts working, but before it was not an issue.

October 3, 2019 at 9:37 pm #4691555

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

October 3, 2019 at 10:03 pm #4691577

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have a few questions. I can see that not any WPML Translation Editor is set.

Which one do you prefer, or which one did you use earlier?

https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/

https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/

Do I understand right, that all this content was earlier translated with WPML or did you import the content from a different website?

If you used WPML earlier it seems that you performed a reset of WPML inside of the troubleshooting options, is this the case?

Kind regards
Andreas

October 3, 2019 at 10:36 pm #4691655

samvelA

Yes, we used WPML and translated all the content with WPML.

We prefer Regular Translation Editor please.

Yes, we did reset

October 4, 2019 at 12:01 am #4691753

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am really sorry, but a reset of WPML deletes the respective tables, saving the information in order to connect the translations. It affects translation and language information that WPML associated with each content type.
https://wpml.org/faq/how-wpml-reset-works/

The workaround here would be to connect the translations manually on the WordPress Editor for pages and posts.

You will need to set the language for each Armenian content to its respective language at the top of the right sidebar. Then go to the respective English content and disable the WPML Translation Editor. Then at the same spot where you changed the language earlier click "Connect with translations" and enter the title of the respective Armenian Content.

Only make sure to assign all Armenian Posts and Pages to their language first.

Let me know if you need further assistance.

Kind regards
Andreas