This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 2 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 8, 2019 at 2:42 pm #4364007

alessioF-18

WHEN I enable your plugin my products stop being loaded and their page becomes unreachable

I cant provide Debug info, because when I start WPML my customers can no longer make purchases

August 8, 2019 at 6:54 pm #4365481

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above, thanks!

August 9, 2019 at 9:55 am #4369257

alessioF-18

Ok, I tried to migrate the website, but i think that because of the intense CPU usage of these days, my provider cut the data stream of the migration, and coused it fails.

Righ now the best solution could be my staging site.

August 9, 2019 at 7:22 pm #4372663

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. A stagging website is fine for the test purposes, please, provide us with the access for it and we'll proceed with our support efforts. Also, please tell us if we can perform tests and change settings in your stagging website. A private reply is now enabled for you, so you can safely provide these access details. Thank you for your collaboration, have a nice day.

August 13, 2019 at 3:35 pm #4389253

alessioF-18

sorry for the late respond.
I had start right now a new migration on cloudways' server.

Today it will probably work.
I will keep you updated when the migration end.

August 13, 2019 at 4:45 pm #4389713

alessioF-18

Migration Completed...but it does not seems to bo really completed... the destination site looks the same as before

August 13, 2019 at 6:52 pm #4390329

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Is it possible to use a stagging website? If you have one it would be nice for our troubleshooting process, if not, then we can try another alternative in case CloudWays keep failing. Please, let me know, have a nice day.

August 13, 2019 at 7:02 pm #4390371

alessioF-18

Yes we could...but the stagin website is a bit slow...if u want i can provide you the credential to try

August 14, 2019 at 2:39 pm #4396115

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Let's try the issue investigation in your stagging environment if it becomes a hard process then we can try an alternative such as a duplicator package or WP All in One Migration. I will enable a private reply so you can safely provide the access details to your stagging website, also, please confirm the permission to perform some tests, change settings, etc. Thank you for your collaboration, have a nice day.

August 15, 2019 at 5:48 pm #4402807

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the pvovided details. I took a detailed look in your website and could reproduce the issue on the single product page. I tried to connect to your website using the provided FTP details but they don't seem to be correct, in fact it connects but it doesn't list your server files/folders, can you please review it?

The reason I need it, is to make it possible to turn on your WP_DEBUG mode and take a detailed look in your log files the cause of this issue which could be related to some servers resources. Thank you for your collaboration and patience, have a nice day.

August 16, 2019 at 8:53 am #4405489

alessioF-18

I updated the path ... I just tried it and ftp works.

I apologize for the inconvenience

August 16, 2019 at 6:55 pm #4407921

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a detailed look in your website using the stagging environment and could notice the issue comes due a possible compatibility issue between the 'SKU Shortlink For WooCommerce' and WPML WooCommerce Multilingual, in order confirmit please, follow the instructions below:

  • Install the theme/plugin in a clean installation and reproduce the problem in this new installation. So we can isolate it and do some testing without the interference of server settings or other plugins
  • After this, I will check the problem in this new installation and look for a quick solution
    If I can not find a solution, I will forward the problem to our compatibility team.
  • The compatibility team will do some more testing and will contact the product author to fix the issue

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the (theme/plugin) to this test install, setup it the same way as in your website (using the same options) and create some dummy content to reproduce the issue. Please note that we only need the (theme/plugin) and the related functionality, you don't need to setup a entire website or clone your existing site. The fewer plugins the better.

After that, please send us clear steps on how to see/reproduce the issue on this test install. We will run some tests.

Please, let me know when you are ready, thank you for your collaboration, have a nice day.

August 19, 2019 at 12:40 pm #4416005

alessioF-18

Ok, I tested my website without SKU Shortlink For WooCommerce and all seems to work.

I add woocommerce, Avada, wpml & Co, SKU Shortlink For WooCommerce in your testing website, and its works....so i dont know why in my website it doesnt works...My hosting plan is GoGeek...so it is the "Best" of the SiteGround shared hosting plans, so i dont think that the problem is the servers resources...what could I do ?

August 19, 2019 at 9:02 pm #4419191

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the details. I took another detailed investigations and noticed your stagging enviroment also worn when I took the actions below:

1 - I created a default .htaccess file with the default .htaccess contend defined by WordPress:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Actually your website .htaccess has a lot of custom rules that could be the culprit here.

2 - I increased your current memory limit available for WordPress from 128M to 256M in your wp-config.php file.

3 - I changed your current product base slug to 'Predefined' in your WordPress Dashboard > Settings > Permalinks

You can see the results at: hidden link

This article may help you to setup your host properly to avoid any redirection loop: hidden link

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

Please, let me know if it helps to fix your issue. Have a nice day.