Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 23 replies, has 2 voices.

Last updated by miroslavB-7 6 days, 18 hours ago.

Assigned support staff: Bigul.

Author Posts
October 20, 2019 at 10:22 am #4789395

miroslavB-7

I am trying to: Be at reasonable speed with my site, provided I am on decent hosting, have good page speed practices and having tried most of solutions provided to similar tickets on WMPL support forum.

Link to a page where the issue can be seen: hidden link

I expected to see: Adequate speed given my semi-premium hosting, highish WP memory limit and otherwise good page speed best-practices (very little plugins, optimized images, caching, CSS + JS minify and concatenate into one file etc.).

Instead, I got: WPML slowing down my site considerably. I have tried turning all of the plugins on and off, even in combination with WPML and one another (quite some number of possible combinations, despite just a few plugins!). I have tried suggestions from other support tickets - turning off (and even back on, also in combinations) auto-registering of IDs, strings, etc. Always emptied cache afterwards and tried anonymous window. Also tried pre-caching DB queries and static content to no avail. When I turn off WPML, my speed is blazing fast again.

Thank you in advance for your help!

October 21, 2019 at 2:32 pm #4795277

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve the issue.

Are you using a shared hosting or VPS service? How much time the site is taking for loading on average when WPML is active?

We have released a new version of WPML(4.3) today. It has a lot of improvements in performance. Please check the following article for more details.

https://wpml.org/2019/10/wpml-4-3-with-revamped-string-translation/

Therefore please upgrade to the latest version of WPML after a full site backup and check is there any difference in the site performance.

--
Thanks!

Bigul

October 22, 2019 at 11:37 am #4801777

miroslavB-7

Hello there, Bigul,

thank you for your recommendations.

I am using a shared hosting, but their most advanced plan (Siteground - GoGeek), which runs my other sites very, very fast. They are similar projects, just without WPML. And one uses WPML as well, which makes it only a little bit slower, which is fine.

However, yesterday I was contacted by my hosting provider that I am using too much server resources with database queries from WPML - just as I thought. They restricted my plan due to this.

I have updated WPML today and yes, it is a BIT faster now, on edge of usability now (yesterday, it was causing 504 gateway timeout errors!). But still it is about 8 seconds loading time when I click on any single product. As I have said - the site uses minimum plugins and very lightweight ones at that (as provided in the debug info). We have also just about 60 products on the store, with little description and optimized photos, caching, CSS + JS minifying etc.

When I turn off WPML, the load time is about 0.5-1 second total. So about 7 seconds faster.

a) Is there please any further tweaking I might do?

b) With the update of WPML - shall I modify my WPML settings (auto-register IDs etc.), or which ones would you recommend to make the site faster?

c) Can I turn off String translation and Translation management when I am not using them? Will the multilingual site run normally with those two plugins turned off?

Thank you Bigul for your help!
Mirek

October 22, 2019 at 3:31 pm #4803807

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Mirek,

Thank you for the feedback. Which tool you are using for analyzing the performance?

WPML String Translation and Translation Management plugins are essential for the translation of WooCommerce. I have the following requests to track the issue. Because would like to discuss this issue with our team.

1) Please switch for a moment to Divi parent theme(after a backup) and check how much time the site is taking for loading

2) Please deactivate all other plugins except WooCommerce and WPML ones, then check how much time the site is taking for loading

3) Please share with me the WordPress debug.log (not WPML debug information). Check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

October 23, 2019 at 12:01 pm #4811149

miroslavB-7

Hello there, Bigul,

thank you for further assistance. I believe we will get the hang of it soon. 🙂

I have been provided with detailed server logs from my hosting account for this purpose, which show that indeed WPML database queries take between 10-30 seconds to execute. Since the last WPML update, this went considerably down, but still, I see in the logs that it is taking very long time due to WPML database queries.

As I´ve said, even when all plugins except WPML are on, the site is very, very fast (0.5-1.5 seconds load).

To answer your suggestions:

1) I have made a staging copy for this purpose (as I cannot wreck my client´s live site), on the same hardware/server. The loading time to first byte, or when I click on a product, and product filtering sidebar are still just the same. Sorry for not being accurate, but just using stopwatch it is still around 5-9 seconds per product, filtering option, or almost any page with dynamic content (product catalog, product page - most of them).

2) I have switched off everything except WooCommerce, WPML and password-protection (the site needs to be locked down - but this password plugin has virtually no impact). The results are still the same, sometimes with 0.5-1.5 second faster time (expected).

3) I have reproduced the steps you´ve mentioned, but no debug.log file was created. Is that because the CMS did not catch any bugs? I have searched the */wp-content/* directory indeed.

Thank you, Bigul,
Mirek

October 23, 2019 at 1:35 pm #4811983

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Mirek,

Thank you for the details. I would like to do some performance testing on your staging site. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

October 28, 2019 at 7:49 am #4836569

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Mirek,

Thank you for the details and login information. The FTP credential of the site is not required for the initial checking. But I am not able to log in to the site because of wrong password. Please check.

--
Thanks!

Bigul

October 29, 2019 at 7:23 am #4844205

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Mirek,

Thank you for the updates. We haven't access the site Dashboard yet. It is still showing the invalid password error.

CHYBA: Chybně zadané heslo pro uživatelské jméno *****. Zapomněli jste heslo

We will not run any scripts on your staging site during the tests. It will be mostly deactivating & reactivating plugins and switching themes etc... We will also do the same tests in our local server to track the issue.

Please check and let me know your feedback.

--
Thanks!

Bigul

October 30, 2019 at 7:33 am #4852977

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Mirek,

Thank you for the updates. I can log in to the site now. One more request. You are using the older version of Divi theme and few plugins including WPML also require upgrading. Please upgrade to the latest versions.

We would like to try with the latest versions because of the version compatibility. Please check the attached images for more details.

--
Thanks!

Bigul

October 30, 2019 at 10:28 am #4854585

miroslavB-7

Hello there, Bigul,

I am glad that it worked out. 🙂 I have updated all plugins and Divi theme.

Please let me know if I can be of any further asistance with this.
Have a good day!
Mirek

October 31, 2019 at 7:58 am #4861029

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Mirek,

Thank you for the updates. I made a Duplicator copy of the site and continuing the performance troubleshooting now. Will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

October 31, 2019 at 11:08 am #4862929

miroslavB-7

Hello there, Bigul,

that´s great news! I believe we will resolve this. I know that WPML can be optimized (I have just read couple of blog posts regarding that) and trust that we will do so together. 😉

Please keep me posted and may you have a good day.
Mirek

November 1, 2019 at 10:15 am #4869547

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Mirek,

Thank you for the updates. I have tried different combinations of active plugins during the performance testing and issue is existing. So shared the details with our team and waiting for the expert opinion. We will get back to you soon. Please wait.

--
Thanks!

Bigul

November 3, 2019 at 11:16 am #4876195

miroslavB-7

Hello there, Bigul,

thank you very much for your support and verifying the issue. I trust that you will handle this. 😉

Have a great day and looking forward to hearing from you!
Mirek

November 4, 2019 at 3:53 pm #4882859

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Mirek,

I had a quick check with WPML 4.3.3, which is released today. But the results are almost the same. Therefore escalating the ticket to our second-tier team for further debugging.

We will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul