This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Vincenzo 7 months ago.

Assigned support staff: Vincenzo.

Author Posts
March 25, 2019 at 3:00 am #3449381

laurentD-22

Hi,

I having trouble trying to make WPML working without "killing" my website...

It is so slow, once it is activated I am not to load a page anymore.
I have to move the WPML files inside /www/wp-content/plugins/ to force the deactivation and get the site back...

I tried everything I found on the forum and nothing helped :/

I have a queries monitor that indicated thousands of queries comming from WPML.

Note that my website only has one language (French) and I only need to translate a couple of modules (that I haven't been able to translate yet).

Here's the list of what I did :

- Made sure everything was up to date
- Disabled "Adjust IDs for multilingual functionality (WPML > Languages)
- Disabled "Track where strings appear" (WPML > String translation)
- Disabled "Auto register strings" (WPML > String translation)
- Disabled W3 Total Cache

-I tried adding this to my theme's functions.php :

function wpml_fix_missing_icl_tables() {
   
    if( function_exists( 'icl_sitepress_activate' ) )
   
        icl_sitepress_activate();
   
}
   
add_action( 'wp_footer', 'wpml_fix_missing_icl_tables' );

- I tried adding this to wp-config.php :

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- I ran this command in the table "wp_icl_strings" :

DELETE FROM `wp_icl_strings` WHERE status = 0;

And it's still slowing the website down...

Here are the specification of our hosting service :

- OVH Performance 1
1vCore, 2 Go RAM
Private SQL : 512Mo RAM

Unfortunately, if I don't find a solution quick enough I will have to find an alternative to WPML as I have to deliver the website next week...

I read about your refund policies, let me know if you have a solution or if a refund is possible.
This is not the solution I'm looking for, as I think WPML is the best extension for translation, but time is against me on this one...

Thank you very much for your help.

Regards,
Doug.

March 25, 2019 at 4:24 pm #3456181

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, thank you for contacting WPML Support!

I understand you are having site performance issues. Since performance issues can be difficult to pinpoint, let's check a few variables and settings to narrow the issue. Please answer as many of these questions as you can. Contact your hosting provider, if necessary.

Please keep WPML and all its add-on plugins enabled while doing these steps (if possible):

1. When WPML is enabled, is the site slow, or it just returns a white page?
Can you please temporarily enable the WordPress' debug mode?

- Open the wp-config.php file and search for this line:

define('WP_DEBUG', false);

- Change it to:

define('WP_DEBUG', true);
define('WP_DEBUG_LOG', true);
define('WP_DEBUG_DISPLAY', false);

Now the errors will be logged in the debug.log file inside /wp-content/ folder.

The wp-config.php file is inside your WordPress root folder.

Enable WPML and visit some backend and frontend pages.

Now, please disable the debug mode and post the most recent content of wp-content/debug.log file here in the forum or on pastebin.com if it is too big.

Related documentation:
- https://wpml.org/documentation/support/debugging-wpml/
- http://codex.wordpress.org/Debugging_in_WordPress
- https://wpml.org/faq/500-error/

2. Can you add debug information to the thread?
Instructions: https://wpml.org/faq/provide-debug-information-faster-support/
If you cannot enable WPML, please add as many information possible about the server environment (eg. WordPress and WPML plugin's versions, PHP version, list of all the active plugins, etc.)

3. If you haven't already, can you review the following articles?
https://wpml.org/faq/prevent-performance-issues-with-wpml/
https://wpml.org/2012/01/can-your-site-run-faster/
- Please ensure that all the relevant steps are followed.

4. Try disabling and re-enabling all WPML plugins and then going to WPML > Support > Troubleshooting and press the "Recreate ST cache tables" button.
The first visit after the re-activation of the plugins is kinda slow, but after the regeneration of the tables - it will be better.

5. Can you confirm that you are still experiencing performance issues with minimal set up (all plugins except WPML disabled and the theme set on a WordPress default such as Twenty Nineteen)?

Thank you for helping us pinpoint the issue. Feel free to add any other information you may have.

The topic ‘[Closed] WPML makes the site so slow it's unusable’ is closed to new replies.