This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Shekhar Bhandari 5 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 17, 2019 at 5:49 am #3831501

andreasH-54

Received the following message from WP 5.2

Fehler-Details
==============
Ein Fehler vom Typ E_ERROR wurde in der Zeile 130 der Datei /www/htdocs/w0183434/jolly-club.at/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php verursacht. Fehlermeldung: Uncaught TypeError: Argument 1 passed to WPML_Media_Post_Images_Translation::translate_images_in_post_content() must be an instance of WP_Post, null given, called in /www/htdocs/w0183434/jolly-club.at/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php on line 107 and defined in /www/htdocs/w0183434/jolly-club.at/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php:130
Stack trace:
#0 /www/htdocs/w0183434/jolly-club.at/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php(107): WPML_Media_Post_Images_Translation->translate_images_in_post_content(NULL, Object(WPML_Post_Element))
#1 /www/htdocs/w0183434/jolly-club.at/wp-includes/class-wp-hook.php(288): WPML_Media_Post_Images_Translation->translate_images(5374)
#2 /www/htdocs/w0183434/jolly-club.at/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
#3 /www/htdocs/w

May 17, 2019 at 6:14 am #3831519

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

I would need your help to narrow down the issue. Could you please provide feedback on the following questions as much as possible?

#1
Could you please remember the steps that created this error? are you trying to update the post?

#2
Could you please go to WPML-> Support ->Troubleshooting and click the below buttons:

+ Clear Cache in WPML
+ Set Language information
+ Fix element types collation
+ Remove ghost entries from the translation tables
+ Assign translation status to duplicated content
+ Set language information

#3
Can you confirm that you are still experiencing issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Nineteen)

#4
Could you please perform the below steps and share me the results?

Debugging

1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Look forward to your reply.

Thanks

May 18, 2019 at 12:08 pm #3838881

andreasH-54

Hello!

Thank you for the detailed reply:
We have tried to reproduce the error, but it did not occur again.

Anyway, it seems, that is was caused by the combination with this plugin:
hidden link

As there where updates of both in the meantime - this plugin and Woocommerce - maybe these have solved also the problem.

We will follow the development and come back to you, if the problem occus again.

Thank you for your support!

Regards
Andreas

May 20, 2019 at 3:15 am #3843261

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello Andreas,

Sure, I will look forward to your reply.

Thanks