This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Itamar 1 year, 5 months ago.

Assigned support staff: Itamar.

Author Posts
May 1, 2018 at 10:24 am #1911170

idaE-2

I am trying to: make my Woocommerce store multilingual, but WPML is causing so many problems. First of all, I get an internal server error when I try to go to the media upload page. Secondly, I can't upload any new photos or access any in my archive. The upload page from a blog post is just completely blank.

When WPML Media is activated, it is also causing problems with my Justified Image Grid. All gallery photos disappear and I get the error message "There are no photos with those IDs" displayed in my posts instead of the gallery.

I have tried to deactivate all my plugins except WPML Media. When I do that I can see some photos in my media archive (I don't get an internal server error), but the images are not my latest photos.

The major problem is also if all my galleries disappear because of WPML Media.

Can you please tell me what to do?

May 2, 2018 at 3:57 pm #1938227

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Thank you for contacting the WPML support forum.

When I check the debug information that you have attached to this ticket I can see something out of the ordinary that might cause the issues that you have.
I can see that in the WordPress settings of your site in Settings -> General the following is set.
WordPress Address (URL) -> hidden link
Site Address (URL) -> hidden link
Is it correct that it is set like this?
I can see that you are using the option 'A different domain per language' in WPML -> Languages. In this case, the above values need to be with the same domain.
The main domain of your site the one with the default language which in your case is Swedish.

If it is indeed not the same, please correct it and see if it corrects the issues on your site.

Thanks,
Itamar.

May 2, 2018 at 5:49 pm #1940344

idaE-2

Hi,
Thank you for your reply. At hidden link the WordPress address URL and site address URL are the same (hidden link).

Though on hidden link I noticed that site address is as you mentioned.

I tried to change this, but if I put hidden link as site address, I can’t access hidden link at all. It just redirects me to my English site.

How should the right setup look? I remembered that I had a lot of problem with setting up WPML in the beginning, and my server provider helped me out.

They put this code in my .htaccess file:

# - FIX for rewrite to wpml
RewriteCond %{HTTP_HOST} ^(www\.)adarasblogazine.com [NC]
RewriteRule ^(.*)$ <em><u>hidden link</u></em> [R=301,L]

Does this look right to you or how can I fix this?
I would really appreciate help to sort all this out.

Best wishes,
Ida

May 3, 2018 at 8:25 pm #1966042

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Ida, from what you write here at the beginning it sounds like you have two separate WordPress installations. One for hidden link and one for hidden link.
Is it correct?

If so then it is wrong when using the option 'A different domain per language'.
In this case, you should have only one WordPress installation, and it should be in hidden link because that is the domain for your default language (Swedish).
In the following article, we explain how to set the server for the option 'A different domain per language'. https://wpml.org/2016/04/use-wpml-different-domains-per-language/

So again, the question is, please do you have two WordPress installation one for each of your domains?

Thanks,
Itamar.

May 3, 2018 at 11:13 pm #1967101

idaE-2

Hi,
I only have one WordPress installation, on adaras.se.
Is that correct?

May 6, 2018 at 11:07 am #1997193

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Ida.

Yes, that sounds correct.

Maybe it will be better if I check things on your site. This way I'll be able to understand better how it is set up.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.
You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.
Maybe I'll need to replicate your site locally. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.
** IMPORTANT **
- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link
 
Thanks,
Itamar.

May 15, 2018 at 10:25 am #2135656

idaE-2

I think I've managed to get the store to work without too many problems. My server provider changed the max execution time on their side. It also seemed like Wordfence was causing most issues.

Now, when it's not installed I don't get internal server errors. However, the site is really slow.

So my final question is if I really need to have Translation Management activated for the multilingual store to work? Or is there a workaround?

Best wishes,
Ida

May 15, 2018 at 10:38 am #2135869

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Ida.
I'm glad that most of the problems are solved now.

If you are using WPML and WooCommerce you must have the Translation Management add-on active.
Why do you suspect that the Translation Management is causing your site to be slow?
Please read our documentation on how to improve site's performance.
https://wpml.org/2012/01/can-your-site-run-faster/

Regards,
Itamar.