This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 2 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 24, 2019 at 10:05 pm #4277627

marcB-48

I am trying to: enable wpml

Link to a page where the issue can be seen: hidden link

I expected to see: looks like everything is working but i get the error message in the admin panel

Instead, I got:

July 25, 2019 at 12:35 am #4278039

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Please, try the following:

1 - Make sure you have the latest updates to the WPML related plugins installed.

See: https://wpml.org/faq/install-wpml/#automated-updates

2 - Deactivate all the WPML related plugins and activate one by one again.

Please, let me know if it fixes the issue. Have a nice day.

July 30, 2019 at 10:21 am #4306879

marcB-48

Hi Marcos,

Unfortunately I still receive the message: "WPML Media is enabled but not effective. It requires WPML in order to work." I have updated all wpml following instructions and deactivate and activate the plugins.
I also got a message saying I had to set up the media translation and I pressed start button and have done that as well.
Recently I have convert my http to https, i see on my account it is set up as http, just in case this may cause the error.
No idea what else to do, looking forward for more instructions. Thanks a lot!

July 30, 2019 at 1:13 pm #4307925

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

July 30, 2019 at 6:43 pm #4310217

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I could confirm the issue in your website. Please, try the following:

1 - Unregister your website and make a new reigstration with a newly created site key as you changed your website url from http to https, following the instructions at: https://wpml.org/faq/install-wpml/#what-do-i-need-to-do-when-the-sites-url-changes

2 - Deactivate all the WPML related plugins and activate them again.

Please, let me know if it fixes your issue. Have a nice day.