This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.98 hours from now. Thank you for your understanding.

This topic contains 12 replies, has 2 voices.

Last updated by katherineZ 9 months ago.

Assigned support staff: Marcel.

Author Posts
August 30, 2019 at 2:29 am #4484305

katherineZ

I am trying to:
get wpml to work
Link to a page where the issue can be seen:

I expected to see:

Instead, I got:
Following your support answers, I deleted all previous wpml plugins and then installed manually and activated only to have the same result.

This site was previously multisite, but I had to change it to single site. Can you help?

August 30, 2019 at 7:51 am #4485151

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Katherine,

Thank you for contacting WPML Support.

The message says that WPML Core is not active. Could you please add me you WPML Debug Info? Here I can see if the WPML Core plugin is active. https://wpml.org/faq/provide-debug-information-faster-support/

Please let me know

Best Marcel

August 30, 2019 at 12:29 pm #4487097

katherineZ

I cannot give you the debug info because WPML is not showing up on the left menu.

August 30, 2019 at 12:43 pm #4487233

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi, then WPML is not activated on your site.

Please go to Plugins -> All Plugins and activate "WPML Multilingual CMS" if you see it in the list or download it at https://wpml.org/de/account/downloads/ and install it manually to your site.

This will solve your issue.

Best Marcel

August 30, 2019 at 12:50 pm #4487279

katherineZ

Okay, if you review my ticket, you will see a screenshot that shows that I have all the plugins activated and registered. Following your wiki, I did not contact support until I had deleted all the plug ins, downloaded the latest version and installed manually through ftp and then activated one at a time.

It shows activated, but is not listed on the side menu and has the warning on top.

August 30, 2019 at 1:04 pm #4487335

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Sorry, there is no screenshot with the activated plugins added. The warning on top means you have only the Add-On WPML Media Translation activated, not WPML Core (WPML Multilingual CMS).

Can you please try if you can open WPML Core using the URL /wp-admin/admin.php?page=sitepress-multilingual-cms%2Fmenu%2Flanguages.php ?

I would need to request temporary access (WP-Admin and FTP) to your site
– preferably to a test site where the problem has been replicated if possible –
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

✙ Please add the Links to the […] Edit Screen, the Page/Post where you insert the […] and the corresponding Front End Page/Screen

Best Marcel

August 30, 2019 at 2:22 pm #4487709

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Thanks, I can confirm it's a user access problem, which is probably caused by the Multisite change.

I can see hidden link a user access problem.

I will try to find a fix for this and update you ASAP.

Best Marcel

September 2, 2019 at 9:02 am #4495547

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Katherine,

Could you please re-check the FTP credentials? I'm getting stuck with "Searching for host". I would need to activate the PHP error log.

Thank You

Best Marcel

September 3, 2019 at 9:54 am #4503157

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Thanks, WPEngine uses Port 2222, that was missing on the credentials.

I tested various options and migrated the site to our Cloudways server where the issue also appears. Also, a reinstallation of WPML didn't solve the problem on the clone.

I consulted our 2nd Tier for their opinion, and I will update ASAP as I receive feedback.

Best Marcel

September 6, 2019 at 12:06 am #4522201

katherineZ

Any news?

September 6, 2019 at 9:32 am #4524381

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Katherine,

For the moment no suggested workaround was working on your site. I added your case already to our bug tracker where a developer will take a look.

Thank you for your patience. I will update you ASAP as I receive a working solution or feedback.

Best Marcel

September 6, 2019 at 2:06 pm #4525713

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Katherine,

now it's working and you can re-configure WPML here in the Menu:

Probably because the Multisite change the DB field in "wp_options" named "_wpml_inactive" was set to "true". We removed this now.

Best Marcel

September 8, 2019 at 12:13 am #4529957

katherineZ

My issue is resolved now. Thank you!