This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Diego Pereira 1 year, 8 months ago.

Assigned support staff: Diego Pereira.

Author Posts
September 24, 2018 at 12:44 pm #2760463

Edita s.r.l.

I am trying to set the following options in the WPML Media Translation options:


As I understand these options, this will allow me to use ALL currently uploaded image in all languages AND all newly uploaded images in all languages.

After setting the checkboxes as shown in the image - I click the 'Start >' button to perform the procedure - wait for it to finish, then click the 'Apply' button.

The problem is that when the page is refreshed - the options have reset themselves to the following:


This problem occurs on all our production sites using WP 4.9.8 and WPML 4.0.7

I have also installed a clean copy of WP 4.9.8 and WPML 4.0.7 with no other plugins and the same problem occurs.

What do I need to do to get this Working?

September 25, 2018 at 6:30 pm #2765003

Diego Pereira

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @Edita s.r.l., welcome to the WPML support Forum!

The first 4 checkboxes are related to scanning the existing media. This process should only be done once. If you select the boxes and click on "Start", it will scan your existing media and assign language information to it.

After that, if you refresh the page and the checkboxes are not checked anymore, this is the expected behavior, because the scan has already been done. So you do not have to worry about that. There is no need to run the scan again.

On the last 3 checkboxes, these should continue to be marked as they are the options for future media files. You must mark the desired fields and click Apply. If you refresh the page and these fields are no longer marked, we will need to investigate further.

If you need more help just let me know.

All the best,