This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 29 replies, has 4 voices.

Last updated by Otto 1 year, 8 months ago.

Assigned support staff: Otto.

Author Posts
September 30, 2016 at 6:56 am #1105333

adriO

Hi Tia, here I am again.....
After updating to the latest versions of the plugins I discovered that my header images are messed up in the Dutch language. I'm using the WP header Image plugin. In English (default) it is all fine. In the correct situation a random header image is displayed. After the update of WPML media it is only shown in the English (default) language and not in the Dutch one. It is in pages and products as well.

Editing a page in Dutch I get a message that no header image is set and that I should upload one.

You can imagine that I'm not happy. Very often when WPML releases updates the most strange issues occur.

I hope you can help me out.

Best regards,

Adri

October 3, 2016 at 9:50 am #1106732

Tia

Hello, Adri. Apologies for not being able to respond sooner.

I have enabled the private box for the site files.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will request to duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:

hidden link

October 6, 2016 at 4:48 pm #1110179

Tia

Thanks, Adri! I will get this checked out.

October 7, 2016 at 7:05 am #1110469

adriO

Thank you, I'm looking forward toe hear from you.

October 11, 2016 at 1:08 pm #1112870

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi Adri,

Sorry for the delay. Tia forwarded your ticket to me, I hope it is ok.

I downloaded the files you posted and installed it on my test environment.

I was unable to replicate the problem you are reporting. After installing the site and the database, I accessed the homepage and the header was displayed correctly. I will attach a picture for you to see.

These are the steps I followed:

- Install the WP files
- Import the database file
- Edit the .htaccess to match with my settings

Should I follow some other step to see the problem?

Thank you.

October 11, 2016 at 2:12 pm #1112955

adriO

Hi Bruno,

No, it is not ok to transfer this ticket to you. Your answer speaks for it self in this matter. I was NOT speaking about the home page but ANY OTHER page. The homepage header is generated by Revolution Slider and the headers of any other page wit WP Display header. So, your answer confirms my negative thoughts of how support questions in general are treated in your organisation.

Didn't you look any further? It seems to me you did not.

I have had to many difficulties with other support people but Tia (and Otto) that I want to be helped only by Tia or Otto. There is simply no trust to convince me that my issues are taken seriously. See for instance: https://wpml.org/forums/topic/yith-wishlist-for-woocommerce-trouble/ I have to take actions myself over and over to be informed and your answer stipulated it also. Nothing personal but that is my experience.

So, if you can't give me a good reason why Tia had to transfer it o you, you have to give it back to her. I DID NOT ASK FOR HER FOR NO REASON!!!!! When there is a good reason, I want it forwarded it to Otto.

Best regards,

Adri

October 11, 2016 at 9:04 pm #1113263

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi Adri,

Nice to see you again :), although I'm sorry you are having issues.

I just get the ticket and I'm closing now (https://wpml.org/forums/users/otto-f/)

I will make a copy of your site tomorrow first thing in the morning and get back to you as soon as I have news.

Thanks for your patience.

Kind Regards,

Otto

October 11, 2016 at 9:19 pm #1113271

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi Adri,

Nice to see you again :), although I'm sorry you are having issues.

I just get the ticket and I'm closing now (https://wpml.org/forums/users/otto-f/)

I will make a copy of your site tomorrow first thing in the morning and get back to you as soon as I have news.

Thanks for your patience.

Kind Regards,

Otto

October 12, 2016 at 6:02 am #1113396

adriO

Hi Otto,

Thank you for taking this issue under your wings. I'm looking forward to work with you on this matter. I hope to see your resonse shortly.

Best Regards,

Adri

October 12, 2016 at 12:57 pm #1113724

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi Adri,

Thank you.

I managed to check the issue on my local copy of your site.

I will try to reproduce it in a clean install with the latest versions. But to complete the information I would need to know with which version it was working properly, so I can also check that.

Also, I added the images on a Dutch page and set it to random. That solved the issue for every page. I understand it's not the best but it may be a quick workaround. Would you mind trying it?

Then, it looks that you can manage the set of header images per language (this can be a nice feature 🙂 ). To do it:
To manage your English header images:
-Go to your WP dashboard
-Select English in the language switcher on the admin bar
-Appearance > Customize > Header image
To manage Dutch header images:
-Go to your WP dashboard
-Select Dutch in the language switcher on the admin bar
-Appearance > Customize > Header image

Thanks for your cooperation.

Let me know your results, please.

Kind Regards,

Otto

October 13, 2016 at 5:57 am #1114229

adriO

Hi Otto, thank you for your reply.

The working version of WPML media is: 2.1.22. Th other plugins are all of the latest versions.
This works, however, I get the message as shown in the attached screenshot.

Concerning your other suggestions: I will try them as soon as I can find the time. I'm a bit busy these days but I think I can follow up on it by tomorrow. I'm curious if your "work around" also works when products are added. In a working situation every product gets its "own" random header image when the product is translated without setting it by myself.

You will hear from me as soon as possible.

Cheerio!

Adri

October 13, 2016 at 12:41 pm #1114671

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi Adri,

I see, anyway is not good to have mixed versions. And sooner or later you will have to update...

I checked with products and the same. Once I added header images in the secondary language (the same or different ones) it works as expected (as far as I can see)

Please, when you can, give it a try and let me know your results.

Have a nice day!

Kind Regards,

Otto

October 20, 2016 at 7:59 am #1119228

adriO

Hi Otto,

Sorry for my late reply but I was very busy lately. Is you may or may not know I'm living on a boat and we had some maintenance to do before winter is coming in. That's done for the most part so I can give attention to the site again.

The workaround you provided works well. However, in my opinion it is not THE solution. Next to that I had to run the Media Translation to get all header images shown in the Dutch language as well (see screenshot). Most of the header images currently in the site are only for development. In the final site there will be more and different images. The way it is right now means more work (I think there will be a 100 different images). And what about when I add extra languages. All has to be done over and over again.

So, for now it's ok but I hope there will be further investigation and maybe contact with the author of the plugin.

Best Regards,

Adri

October 20, 2016 at 8:38 pm #1119939

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi Adri,

Can you please tell me with which versions of our plugins and the WP Header Display plugin the behaviour is the one you need?

Anyway, I'm not sure if this change is an improvement or a problem... I see your point, but I can also imagine many users wanting the one we have now.

I'll do some tests with once I have the information I just asked and check the issue with our compatibility team.

Thanks for your cooperation.

Kind Regards,

Otto

October 21, 2016 at 7:40 am #1120085

adriO

Hi Otto,

The WP Header Image is not updated for a long time so that is still version 4.
I had update the WPML plugins to their current, latest version and all was well, the functionality was as expected until I updated the WPML media plugin. Before the update I was working with the current versions of that moment so that has to be the second to last ones.

The "old" good working version was 2.1.22.
I have to say: working for a while with only an outdated WPML Media plugin throws me a message that the whole WPML configuration was not working properly so if it is ultimately caused by the Media plugin is a bit dark for me.

If necessary I will revert the site to a former version to get more information, just let me know.

I can see your point why users may want the way it works with separate images for each language so it would be great if users can choose between behaviors.

Best regards,

Adri