Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 3 voices.

Last updated by Fabio Fava 1 year, 9 months ago.

Assigned support staff: Otto.

Author Posts
November 25, 2018 at 2:46 pm #2937673

Fabio Fava

I am trying to: Translate media's Alt Text and Title, and Upload the other languages versions.

Link to a page where the issue can be seen: hidden link

I expected to see: I expected to be able to add translated Alt Info & Title to media, and upload the same medias but on the other languages of my site.

Instead, I got: The "Save" button is greyed-out when I try to add the translations and upload the versions. If I upload, the file is actually uploaded but the translations are not enabled, and I'm not sure the uploaded language versions imaes will be attached to the original English image.

Thank you I'll keep looking forward from you on that, cheers!

November 26, 2018 at 2:26 pm #2940530

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

I could not reproduce the issue in a test WP installation. It looks like a compatibility issue.

To check it, if it is possible for you, do this test:
***Backup your site and DB before proceeding***

-Deactivate all the plugins but WPML and its addons
-Switch to a default WP theme (Twenty Sixteen for example)
-If the issue is gone, reactivate one at a time to see with which one is the conflict

Let me know your results, please.

Kind regards,

Otto

November 26, 2018 at 2:54 pm #2940705

Fabio Fava

Hello Otto, sorry to inform but another WPML Supporter (on a different topic) told me this is a known issue and suggested me to try the Bet Channel, wich I'm not ready to try. I've already done a full plugin conflict test, and it was confirmed by that supporter on the issue of being impossible to operate Media Translator properly. I hope it gets fixed soon, since my site will be Live in a couple months and it would be important to have those images working per-language. Cheers.

November 26, 2018 at 5:11 pm #2941449

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thanks!

What David told you is that there are many changes in WPML Media next version. And that this problem may be fixed there. But it is not confirmed.

If you can test it, it would be great.

If you prefer to wait for the stable version, it is expected for this week. But I can't promise.

Kind regards,

Otto

December 5, 2018 at 9:43 am #2969423

Michelle

Hi I am also having the same issue on two sites in development using WPML and this issue is really stalling all procedures, content updates, development and production progress. Please let me know where I can get the beta version, as well as when a fix will be shipped.

Thanks

December 5, 2018 at 12:45 pm #2970038

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi,

WPML 4.1.1 was already released.

If the issue persists, please open a new ticket.

Kind regards,

Otto

December 5, 2018 at 4:56 pm #2970965

Fabio Fava

Hey Otto, thanks for hitting back.

I've updated and I'm now running the lates version of everything. But Media Translation stills not allowing me to change things. I've managed to upload the translated images and use them on the translated pages (using Cornerstone Visual Page Builder by Themeco). I think I can handle like this.

Please let me know if is there any setting I can change (I still assume is a mis-config of my party) and best regards.