This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 20 replies, has 2 voices.

Last updated by Lauren 7 months, 2 weeks ago.

Assigned support staff: Lauren.

Author Posts
February 15, 2019 at 7:16 pm #3206444

ann-catrineJ

I am trying to:
On quattroporte.se I have used WPML many years and it's been working without any problems but since about a week I have really big problems with memory and can't edit the pages or if I can it's extremely slow (I also have this problem with a new site I'm working on so something is seriously wrong). I've been in contact with my webhost and your support. These changes have been made:

I have added to wpconfig.php:
define('WP_MEMORY_LIMIT', '256M');
define('WP_MAX_MEMORY_LIMIT', '256M');

Webhost has changed this in htaccess:
php_value memory_limit 512M

Webhost has changed this in php.ini (suggestion from you):
Also, check the max_input_vars settings of your server. Please increase it to 10000. There are two options to do this:
== php.ini file
Open the php.ini file and insert/edit this line:
1

|max_input_vars = 10000|
hidden link
== .htaccess file
1

|php_value max_input_vars 10000|

The web host say they can't do anymore. What can you do to make WPML work? Please help.

Link to a page where the issue can be seen:
hidden link

I expected to see:

Instead, I got:

February 18, 2019 at 4:34 pm #3213325

ann-catrineJ

Please help!

February 19, 2019 at 1:11 pm #3216685

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this. You mentioned you have a problem with the memory. Are you seeing an error about memory?

I understand you are having site performance issues. Since performance issues can be difficult to pinpoint, let's check a few variables and settings to narrow the issue. Please answer as many of these questions as you can. Contact your hosting provider, if necessary.

Please keep WPML & all related plugins enabled while we do these steps:

1. If you haven't already, can you review the following article https://wpml.org/2012/01/can-your-site-run-faster/ to ensure all relevant steps are followed?

2. Can you confirm that the following settings:
- Adjust IDs for multilingual functionality (WPML > Languages) - disabled
- Track where strings appear (WPML > String translation) - disabled
- Auto register strings(WPML > String translation) - enabled

3. Can you tell me more information about the hardware including the CPU?

4. What type of hosting do you have? Shared, VPS, Dedicated, etc?

5. Do you know if object caching is part of your PHP setup? PHP < 5.5 should be APC. Newer versions should use the zend op cache, uAPC will also work though but is slower.

6. Can you confirm that you are still experiencing performance issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Fifteen) ?

7. Are you using a cache plugin such as W3 total cache?

8. Make sure Disk caching is disabled.

9. Try disabling the W3 total cache plugin.

10. Please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

-Browse to the page with the issue and/or reproduce the issue.

-Locate the debug log in: /wp-content/debug.log

-Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

Thank you for helping us pinpoint the issue. Feel free to add any other information you may have.

February 19, 2019 at 2:04 pm #3217033

ann-catrineJ

Thanks for your reply! Ok, I will follow the list and will get back to you.

February 19, 2019 at 2:33 pm #3217132

ann-catrineJ

Hi again, before I go on: there's this error message on the site. It says "The update of WPML is not completed", but looking under plugins it doesn't tell me to update. Maybe this should be solved before I go on working on the list?

Thanks

February 19, 2019 at 5:27 pm #3218322

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please try to to do a manual update by following these steps:

1. Ensure that you have a full backup for the site.

2. Log in to your WPML.org account and go to the Downloads section. Download the WPML components that you need. You will receive a ZIP file for each one of WPML’s components.

3. Deactivate the current WPML version that you are using. Be sure to deactivate WPML and all its components. Otherwise, the installation files may be locked and not writeable. Don’t worry, your translations are not going to be modified.

4. Delete the plugin, so that you can install the new version. Note: if you cannot delete from inside WordPress, use an FTP program to delete the folders of WPML and its components from wp-content/plugins.

5. In the WordPress admin, go to Plugins -> Add New -> Upload and upload the ZIP files that you downloaded. Alternatively, if you cannot upload plugins directly to WordPress, unzip each file. A directory will be created. Then upload the unzipped directories to your site’s ‘wp-contents/plugins’ directory and overwrite the existing folders for WPML and its components.

6. Log in to your site, go to Plugins and activate WPML core first and then its components.

March 3, 2019 at 7:26 pm #3266572

ann-catrineJ

Hi,

Please view my replies below. I've added "–– " before the replies so that they're easier to spot. Let me know when you've had look at it. Also, should I erase the debug info in the wp-config-file? Thank you

1. If you haven't already, can you review the following article https://wpml.org/2012/01/can-your-site-run-faster/ to ensure all relevant steps are followed?
–– I have installed WP Super Cache, but it’s difficult to know what settings to use when there are warnings at some of them. I don’t want to make things even more complicated…

2. Can you confirm that the following settings:
- Adjust IDs for multilingual functionality (WPML > Languages) - disabled
- Track where strings appear (WPML > String translation) - disabled
- Auto register strings(WPML > String translation) - enabled
–– I’ve done these.

3. Can you tell me more information about the hardware including the CPU?
–– I’m working on different computers and get the same problem. My main computer is:
Mac Book Air 2017
Processor: 2,2 GHz
Memory: 8 GB 1600 MHz DDR3
OS: Mojave 10.14.3

4. What type of hosting do you have? Shared, VPS, Dedicated, etc?
–– Not sure about this, but am using one of the biggest and best web hosts in Sweden, very professional. They’re using UNIX-hosting.

5. Do you know if object caching is part of your PHP setup? PHP < 5.5 should be APC. Newer versions should use the zend op cache, uAPC will also work though but is slower.
–– Using 7.2

6. Can you confirm that you are still experiencing performance issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Fifteen) ?
–– When I disable WPML everything works fine.

7. Are you using a cache plugin such as W3 total cache?
–– No

8. Make sure Disk caching is disabled.
–– Where do I do this?

9. Try disabling the W3 total cache plugin
–– Don’t use it.

10. Please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress
Edit wp-config.php and insert the following lines:
1 define( 'WP_DEBUG', true );
2 define( 'WP_DEBUG_LOG', true );
3 define( 'WP_DEBUG_DISPLAY', false );
-Browse to the page with the issue and/or reproduce the issue.
-Locate the debug log in: /wp-content/debug.log
-Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

–– This is all the text:
[03-Mar-2019 18:49:17 UTC] PHP Deprecated: Function create_function() is deprecated in /www/webvol5/ba/ylo9nq8m1wv578s/quattroporte.se/public_html/wp-content/plugins/easy-facebook-like-box/facebook-like-box.php on line 257
[03-Mar-2019 18:49:26 UTC] PHP Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 577536 bytes) in /www/webvol5/ba/ylo9nq8m1wv578s/quattroporte.se/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-otgs-installer-autoloader.php on line 13
[03-Mar-2019 18:49:26 UTC] PHP Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 577536 bytes) in /www/webvol5/ba/ylo9nq8m1wv578s/quattroporte.se/public_html/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/persist/class-wpml-st-page-translations-persist.php on line 215

Thank you for helping us pinpoint the issue. Feel free to add any other information you may have.

March 4, 2019 at 2:54 pm #3269399

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for enabling debug log. The last error that shows is saying that your site is out of memory. Please try increasing memory even higher than you already did. It looks like it is trying for over 530MB, so you need to make it something higher than that.

Also, I understand that you say performance is better when you deactivate WPML. Please also try this - deactivate NON WPML plugins and switch temporarily to a default theme such as Twenty Seventeen. WIth these settings, is performance better? This will help me identify if there is a conflict with a plugin or theme causing the poor performance.

Lastly, the server caching can be disabled by your hosting company.

Please let me know the results of these tests. Thanks!

March 4, 2019 at 3:05 pm #3269449

ann-catrineJ

Hello, ok thanks i will go through your suggestions. Just a question: where do I add the 530MB? (in htaccess or wp-config?)

thanks

March 4, 2019 at 3:12 pm #3269489

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

You add it in wp-config.php. You need to just change what you added previously, so that the MB is higher.

March 4, 2019 at 3:15 pm #3269507

ann-catrineJ

Ok, so:
define('WP_MEMORY_LIMIT', '530M');
define('WP_MAX_MEMORY_LIMIT', '530M');

is this correct? I just want to make sure I add it correctly 🙂
thanks

March 4, 2019 at 4:27 pm #3269888

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

You need to go higher than 530, because the site is already requiring more memory than that. I would suggest going as high as you can, and you may want to ask your hosting provider to make sure they don't have their own max amount.

March 4, 2019 at 6:48 pm #3270399

ann-catrineJ

Hi again,
I've checked with the host and to get more memory I would need to use their Business Plus, which is for big companies. This company is a small company and I do hope that WPML should be able to work for smaller companies as well?

March 4, 2019 at 6:49 pm #3270403

ann-catrineJ

I will go ahead and try a different theme and will let you know how if it works better then.

March 4, 2019 at 6:59 pm #3270427

ann-catrineJ

Hello again,

Now I've tried deactivating all non-WPML plugins and tried to change to theme Twenty Seventeen. When I tried to change to that theme with the WPML plugins on it wasn't possible - the page went blank. When I turned the WPML plugins off I was able to change to that theme.

So what else should we do?

thank you

The topic ‘[Closed] WPML memory problems’ is closed to new replies.