This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.36 hours from now. Thank you for your understanding.

This topic contains 9 replies, has 2 voices.

Last updated by Andreas W. 8 months, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
February 5, 2019 at 12:12 pm #3161757

robertoF-14

The plugin changes the colors and font of the site. What happens? He also removed the logo from me. How can I return as soon as possible please help me.

See on charlicharger.com

February 5, 2019 at 11:24 pm #3163744

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for contacting WPML Support.

Could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 768M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

It seems to appear that this issue is theme related. Some themes allow you to set different settings according to the language you visit. Could you go to your theme options and verify that your options have been set equally for all languages? For this, click on the top bar language switcher.

You also can export your theme settings for your main language, and repeating the procedure above, select other languages and import them.I found the following thread on the theme developers website:

hidden link

It appears that this theme uses different style.css files for different languages.

Comment:
"Thanks for pointing me in the right direction polynome. I fixed it now by overwriting the enfold_child_nl.css with the enfold_child.css."

I hope this solves the issue, otherwise please contact us again on order to assist you.

Kind regards
Andreas

February 7, 2019 at 10:21 am #3169580

robertoF-14

Hi,
the problem persists the memory limits are raised to 256M from the provider.

Thanks again for the help

February 7, 2019 at 5:01 pm #3171598

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

February 8, 2019 at 4:26 pm #3176169

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

Could you please update WPML and its add-ons to the latest version
and let us know if the issue persists?
Before doing it, please create a reliable backup of your site.

Further, could you please switch to the default Enfold theme to see if the issue persists? Might it be that your Child theme customization is causing the issue?

Then, I was able to locate options for your Enfold theme at String Translation by choosing the option "translate texts in admin screens". I marked the checkboxes for the respective CSS strings on the avia_options_enfold_child domain and they are now translatable with String Translation. Anyhow those changes do not apply on the translated page.

It might be that we are handling here a compatibility issue between theme and plugin which for I would kindly like to ask you to verify if the issue still appears when using the default Enfold theme. Did you add any custom code to your child theme?

Are you using any server side caching? If so, please disable it to see if the issue persists. It might be that the cache is causing an older .css-file to be loaded instead, which inherits the changes.

Kind regards
Andreas

February 9, 2019 at 1:11 pm #3178461

robertoF-14

Hi
I have disabled SG Optimizer and in English and everything is back to normal. Instead in the Italian one, the problem persists. There is also the problem that when I put the site in Italian I go up for example: gallery and put me in English, ie it does not remain in the language that I chose.

If you can help everything and started from when I changed the default Italian into English. Not immediately it took about a week.
The site is now in maintenance mode. In case if you wants to do some tests. Please solve the problem as soon as possible.

Thanks a lot of your help is time

February 11, 2019 at 12:23 pm #3182811

robertoF-14

Hello,
there are news?

February 11, 2019 at 4:55 pm #3184540

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

Thank you for your patience.

I have checked your site and I realized that the issue is only appearing with your child theme. Switching to the default Enfold theme does not show any issues. Therefore the issue is most likely caused due to custom coding.

I can also see that you added a custom language switcher. Please verify if this code was added properly.
https://wpml.org/documentation/getting-started-guide/language-setup/custom-language-switcher/

Please take not that our support policy does not cover any custom coding solutions.
https://wpml.org/purchase/support-policy/

In this case I would kindly advise you to contact one of our contractors.
https://wpml.org/contractors/

Thank you.

Kind regards
Andreas

February 12, 2019 at 6:35 pm #3190422

robertoF-14

I have put everything in place for now. But now I'm on the contact page and I want to change the language from English to Italian go to the home page I can not see the other pages in Italian only the home. How can I repair?

February 12, 2019 at 9:04 pm #3190938

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

Thank you for your message.

Pages are only available on FrontEnd once the have been translated to 100% when translating them for the first time. Please complete the translations for the pages "CharLi", "Gallery", "Home" and "Privacy Policy". The page home is actually only translated to 80% and I am not sure why the symbol for the translation is not indicating this: Please complete the translation as well.

The pages should then be linked correctly from the the Menu. Further, you are able to sync your menu once the pages have been translated to 100%. You will find this option at WPML -> WP Menu sync.

Please let me know if you need any further assistance.

Kind regards
Andreas