Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Riffaz 4 months, 3 weeks ago.

Assigned support staff: Riffaz.

Author Posts
June 20, 2019 at 9:07 am #4057895

nielsC-4

I am trying to: Add widget of call to action in blog page

Link to a page where the issue can be seen: hidden link

I expected to see: Call to action widget

Instead, I got: to see that only when I deactivate WPML Multilingual CMS.

June 20, 2019 at 11:10 am #4059281

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

How did you create those call to action buttons?
Do you use any plugin for that?
Does it come with your theme?

Debugging
1. Please follow the debugging information provided here: https://wpml.org/documentation/support/debugging-wpml/#enabling-the-built-in-debugging-feature-in-wordpress.
2. enable WPML
3. Repeat the action of creating the problem.
4. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see

Let me know.

Regards,
Riffaz.

June 20, 2019 at 11:58 am #4059633

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

So this is a widget.
Anyhow by default If you do not translate the widget it should show the same widget in the second language as well.

Please enable the WP Debug mode and check if you get any errors when you switch the language.

within your wp-config.php file please replace

define('WP_DEBUG', false);

with

ini_set('display_errors','On');
ini_set('error_reporting', E_ALL );
define('WP_DEBUG', true);
define('WP_DEBUG_DISPLAY', true);

[These don’t affect your site in any way.]

Also, please refer : https://wpml.org/documentation/getting-started-guide/translating-widgets/#registering-widget-fields-for-translation-via-string-translation

Regards,

June 20, 2019 at 12:27 pm #4059945

nielsC-4

Unfortunately it’s not easy for us to change this. We can’t access the SFTP easely. Maybe there is another way to do this?

Yes, There is a error in dropdown is missing so not able to switch languages of pages.

June 20, 2019 at 1:51 pm #4060469

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

To identifiy the possible cause of this we need to enable the WP Debug.

Anyhow, the next reply is private.
Could you please create a temporary admin user and let me know the login details to check this closely?

Regards,

June 22, 2019 at 6:04 am #4070571

nielsC-4

Hi,
I have created amin id for you.But this message is not private. Can you make it private so I can send you details

June 22, 2019 at 7:28 am #4070611

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

The next reply is set to private.

Regards,

June 25, 2019 at 6:31 am #4081545

nielsC-4

THanks for your help! I tried to follow you steps, but it did not work for me. Please check the screenshots. Any idea what's wrong?

June 25, 2019 at 12:58 pm #4084741

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Can I do the migration for you?

Regards,

June 26, 2019 at 7:21 am #4089993

nielsC-4

Hi,

Yes, you can. Go ahead, Thanks!

June 26, 2019 at 11:28 am #4092027

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I checked it.
Some of the settings or plugins are prevent something on your site.
I could duplicate even using the duplicator plugin.

Also, if I go to hidden link it goes to 404
It should not be.

And a lot of javascript error on you console.
All these should be fixed before proceeding further.

As it is a live site it may cause some issue when you disable plugins.
But if you can disable all the plugins and check the issue.

You said you did not find any error message.
During the duplicating attempt I see a really huge file of log.
Please go to /wp-content/ folder
Find the file 'debug.log'
Send it to me.

So we can find something useful.

Regards,

June 26, 2019 at 12:03 pm #4092255

nielsC-4

Hi,

Unfortunately, I'm not able to access that file, because I don't have access to the FTP. Is there another way to test this.

You weren't able to find the problem after making the migration and testing the copied website?

June 26, 2019 at 12:05 pm #4092269

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I could not duplicate and I could not migrate.
Something is preventing doing it from your site.
So we must need cPanel or FTP login to check this now.

Do you have any firewall or security settings or plugin in your site / server?

Regards,

The topic ‘[Closed] WPML Multilingual CMS BUG’ is closed to new replies.