This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 43 replies, has 3 voices.

Last updated by Bigul 1 year, 1 month ago.

Assigned support staff: Bigul.

Author Posts
August 31, 2018 at 1:53 am #2692186

khalidf

Hello,
This exact plugin causing an error when it's active, and the error disappear ones it is deactivated which i tested so many times ... "WPML Multilingual CMS"

The error happens when i try to edit posts or pages, once clicking on Edit link it opens to me an error page with the content below ..
Plus i am not a developer to edit the config file as you recommended in a previous ticket, so please try to find another way to fix the issue.

I would appreciate to be fixed quickly, because i spent so much time already to know that this exact plugin is associated with so many weird errors and crashes in my website....

"
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
"

August 31, 2018 at 7:11 am #2692770

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Are you getting the same result in all the Child Sites? Please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion)

--
Thanks!

Bigul

September 1, 2018 at 12:14 am #2695237

khalidf

Could u please get in this ticket and get the information
https://wpml.org/forums/topic/issue-with-wpml-multilingual-cms/#post-2667442

The time differance with ur friend is killing me and please it is urgent to solve, i can not wait to after the weekend to solve it :((((??

September 1, 2018 at 6:16 am #2695689

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have login to your FTP and added the code to enable Debug mode in wp-config.php file. But I am unable to access your WordPress site Dashboard because of wrong username/password. Please check the attached image and share me the correct credentials to access your site Dashboard.

Just to make sure, are you getting the Internal server error while editing all the Posts/Pages?

Please note, sorry we have very limited support on the weekends.

--
Thanks!

Bigul

September 1, 2018 at 12:23 pm #2695954

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. The debug log is showing the following PHP notices and errors when I tried to edit a Post or Page. The error is related to Slider Revolution plugin. So I deactivate Slider Revolution plugin for testing now, but the site is showing the same error. Therefore I have a request. Please try once again after clearing the server-side caches.

[01-Sep-2018 12:10:55 UTC] PHP Notice:  Use of undefined constant edit_url - assumed 'edit_url' in /hermes/bosnaweb21a/b1939/ipg.giftsbuzzcom/wp-content/plugins/woocommerce/includes/admin/class-wc-admin-dashboard.php on line 363
[01-Sep-2018 12:10:55 UTC] PHP Notice:  Use of undefined constant number - assumed 'number' in /hermes/bosnaweb21a/b1939/ipg.giftsbuzzcom/wp-content/plugins/woocommerce/includes/admin/class-wc-admin-dashboard.php on line 363
[01-Sep-2018 12:10:55 UTC] PHP Notice:  Use of undefined constant customer - assumed 'customer' in /hermes/bosnaweb21a/b1939/ipg.giftsbuzzcom/wp-content/plugins/woocommerce/includes/admin/class-wc-admin-dashboard.php on line 363
[01-Sep-2018 12:10:55 UTC] PHP Notice:  Use of undefined constant blog - assumed 'blog' in /hermes/bosnaweb21a/b1939/ipg.giftsbuzzcom/wp-content/plugins/woocommerce/includes/admin/class-wc-admin-dashboard.php on line 366
[01-Sep-2018 12:10:55 UTC] PHP Notice:  Use of undefined constant blogname - assumed 'blogname' in /hermes/bosnaweb21a/b1939/ipg.giftsbuzzcom/wp-content/plugins/woocommerce/includes/admin/class-wc-admin-dashboard.php on line 366
[01-Sep-2018 12:10:55 UTC] PHP Notice:  Use of undefined constant status - assumed 'status' in /hermes/bosnaweb21a/b1939/ipg.giftsbuzzcom/wp-content/plugins/woocommerce/includes/admin/class-wc-admin-dashboard.php on line 370
[01-Sep-2018 12:10:55 UTC] PHP Notice:  Use of undefined constant status_name - assumed 'status_name' in /hermes/bosnaweb21a/b1939/ipg.giftsbuzzcom/wp-content/plugins/woocommerce/includes/admin/class-wc-admin-dashboard.php on line 370
[01-Sep-2018 12:10:55 UTC] PHP Notice:  Use of undefined constant formatted_total - assumed 'formatted_total' in /hermes/bosnaweb21a/b1939/ipg.giftsbuzzcom/wp-content/plugins/woocommerce/includes/admin/class-wc-admin-dashboard.php on line 373
[01-Sep-2018 12:11:28 UTC] PHP Fatal error:  Out of memory (allocated 183238656) (tried to allocate 32 bytes) in /hermes/bosnaweb21a/b1939/ipg.giftsbuzzcom/wp-content/plugins/revslider/includes/slide.class.php on line 55
[01-Sep-2018 12:15:01 UTC] PHP Fatal error:  Out of memory (allocated 183238656) (tried to allocate 78 bytes) in /hermes/bosnaweb21a/b1939/ipg.giftsbuzzcom/wp-content/plugins/revslider/includes/slide.class.php on line 55
[01-Sep-2018 12:16:12 UTC] PHP Fatal error:  Out of memory (allocated 183238656) (tried to allocate 7 bytes) in /hermes/bosnaweb21a/b1939/ipg.giftsbuzzcom/wp-content/plugins/revslider/includes/slide.class.php on line 55

Which hosting service you are using? Is it a shared hosting or VPS space?

If you are still having the issues, please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

September 1, 2018 at 2:08 pm #2696032

khalidf

Hi, we have the php cash already disabled and still having the issue.
You can go a head with duplicator.
My hosing is "Ipage", and it is shared hosting server

September 3, 2018 at 7:03 am #2698033

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the permission and updates. But I am not able to make Duplicator when I trying to make a package with your site files and database because of Internal Server. The result is the same after several tries and with Duplicator Pro and Free versions. Please check the attached image. Therefore I am downloading the site files via FTP now.

I will configure it manually on my local server after finishing the site downloading(via FTP). Then debug it further and get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

September 4, 2018 at 12:54 am #2701206

khalidf

Hi,
I know you still working but i need to mention something it could be related to the problem that i just realized.
I created multi sites, /ar-sa/, /ar-ae/ as subdirectories, and they didn't working properly for some reason, after that i just created new versions of languages in WPML with the same names /ar-sa/, /ar-ae/, which led to conflict i guess, and my website kept crashing and the hosting support didn't know the reason of the crashing, so i went to the supdirectories from the multi sites and deleted the subdirectories, and kept WPML as it is..
Before creating the multisites subdirectories & the WPML languages, everything was fine, and i was working with all WPML plugins properly and i was editing all posts and pages...
So could even after i deleted my subdirectories from the multisites, there is something causing conflict with WPML .. I am not sure .. i just needed to mention that...

Thanks

September 4, 2018 at 1:09 pm #2703481

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for sharing the updates. I am trying to configure your site backup on my local server now. Because of the Multisite environment, it is having some conflicts(redirection errors). Therefore trying to configure it with help of our team. I will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

September 4, 2018 at 5:01 pm #2704179

khalidf

Hi,

There is so many ads have been placed on the website that were not existed before ... which looks spamy ... they have just appeared after you started to work on this task .. so r u not using any security ???? .. specially you are donloading the stuff on your server ... can you please confirm security and cleaning up the website .. it is already not in good codition because of your plugin ....

I didn't take any action on the website or installing or dowloading any thing since you started the task already ..

September 4, 2018 at 5:08 pm #2704185

khalidf

How can i know that the website info and credentials not leaked to some where after i just got the ads placed on the website as spam after i have shared the logins with you ????????????????????

September 4, 2018 at 5:40 pm #2704240

khalidf

please reply urgently for my this, because i need to change the logins info ..

September 4, 2018 at 5:41 pm #2704241

julizarS

Hallo..

Sorry I have to contact you from here since I have a problem to get debug code because of error on WPML Multilingual CMS

-----------I need your help please-------------

-----------Please create me a ticket for this issue-----------

Tell us what you are trying to do? Remove the plugins

Is there any documentation that you are following? no

Is there a similar example that we can see? hidden link

What is the link to your site? hidden link

Hallo..

I have a problem with WPML Multilingual CMS plugins. If I activated it, my website error 500 like screen shot above.

I nedd you to help me to fix this, since our team have been working the whole day to find the error souces on our web coding and finally find the sources is from WPML Multilingual CMS

I cant give you debugging file because there are no WPML on admin dashboard

Thanks

September 4, 2018 at 5:53 pm #2704302

khalidf

It is ur responsibility now to clean up this virus codes ..

September 4, 2018 at 6:30 pm #2704379

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Sorry to hear about the Virus issue. For your kind updates, I am using a secured system and Antivirus. We haven't had such issues. I went through your site. But not able to find any Malware. Therefore please share more details. Because I can't see anything else than those 2 Google ads in the homepage. I also check your site in Sucuri and the result is fine. Please check the following URL for more details.

hidden link

Please note, I have configured your site copy on my local server. Then updated a couple of pages and posts. It is working fine for me. Please check the attached images for more details. So I will cross check about this with our team.

--
Thanks!

Bigul

The topic ‘[Closed] "WPML Multilingual CMS" causing "Internal Server Error"’ is closed to new replies.