This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

No supporters are available to work today on this forum. Feel free to create tickets and we will handle it as soon as we are online. Thank you for your understanding.

This topic contains 9 replies, has 2 voices.

Last updated by julizarS 1 year ago.

Assigned support staff: Bigul.

Author Posts
September 5, 2018 at 12:48 am #2704978

julizarS

Tell us what you are trying to do? Remove the plugins

Is there any documentation that you are following? no

Is there a similar example that we can see? hidden link

What is the link to your site? hidden link

Hallo..

I have a problem with WPML Multilingual CMS plugins. If I activated it, my website error 500 like screen shot above.

I nedd you to help me to fix this, since our team have been working the whole day to find the error souces on our web coding and finally find the sources is from WPML Multilingual CMS

I cant give you debugging file because there are no WPML on admin dashboard

The debugging code below it not belong to this website so that I have to take it from other site in order the be able to create a support ticket.

Thanks

September 5, 2018 at 5:38 am #2705601

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

When WPML is activated you are getting Error 500, for an example while visiting a Page or editing a Page etc... Am I right?

Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

September 5, 2018 at 4:03 pm #2708114

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates and login information. I went through the WPML settings and it looks fine. Also went through the frontend and backend of the site, but not able to reproduce the issue. Please enable the WordPress Debug mode on for now. It will help us to track the error in case of Internal Server error.

To enable it, open your wp-config.php file and look for define('WP_DEBUG', false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file. Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

--
Thanks!

Bigul

September 6, 2018 at 12:58 am #2708983

julizarS

Hallo Bigul

I have implemented your suggestion and this is the debug log

Debug information edited

September 6, 2018 at 7:10 am #2709667

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. But the one you have shared is Debug information. Which is different from WordPress Debug log. If WordPress Debug mode is on, we can find the Debug log details in the */wp-content/* directory. Please check and let me know your feedback.

Are you still having the error 500 with WPML?

--
Thanks!

Bigul

September 6, 2018 at 2:26 pm #2711072

julizarS

Hallo Bigul..

Thanks you for your help. Please download the debug file here: hidden link

I try to sent it here but seems the file too big and couse error on sending message

Thanks

September 6, 2018 at 5:01 pm #2711775

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the debug log information. But it is not showing any warning or error related to WPML. But you can keep Debug mode on. Becuase it will help us to track in case of Internal Server.

Please let me know now you can reprodue the Error 500(when WPML active) or not.

--
Thanks!

Bigul

September 13, 2018 at 12:59 am #2729260
julizarS

Hallo Bigul.

Our team can solve the error 500 and now we have other problem.

I am sure few days adgo I hev finish translated all cities on Taxonomy Translation and today found the other problem that there are some cities are not yet translated.

If I check in Bahasa Indonesia Version, only have one city but if I go to english and chinese page there would be double cities if I translate it again.

How to find:

Go to string translation--> Select the taxonomy to translate: Property City--> Show: Untranslated Property City. There you can find the city that are not yet translated.

If I go and translate them back, there will be 2 city with the same name

Sample: If you check the property city on admin dashboard --> RealHomes -->Property Cities and then type the city name that not yet translated display on Untranslated Property City, you will see the city already available:

Sample:

Yogkakarta. See on Untranslated Property City there is city name: Yogyakarta. and then if you to admin dashboard --> RealHomes -->Property Cities you will also fine city "Yogyakarta".

The problem is: If I translate it again from Untranslated Property City, there will be double city name yogyakarta and the url will be added caracter "2" at the end of the url

Please help me to solve the problem

Thanks

DEBUG INFORMATION Edited

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/split-taxonomy-translation-issues/

September 13, 2018 at 12:26 pm #2731415

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have opened a new ticket for the Taxonomy Translation issues. Because as per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket.

I will get back to you soon on the new ticket. Please wait. Thank you for the understanding.

--
Thanks!

Bigul

October 3, 2018 at 7:52 am #2783827
julizarS

Hallo Bigul,

I have an issue with WPML Multilingual CMS. If I create or edit post fproperty, caused error like this: hidden link and also many error on server log like this: hidden link

Please create me a ticket since I cant find the way to create ticket anymore

Thanks

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/split-wpml-multilingual-cms-creating-error/