This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I couldn't update your plugin for some time. Then your support helped me update it 2 days ago. Since then my website has been deformed. If I deactive the plugin it all comes back to normal.

Solution: The cause of the issue is the Autoptimize plugin, I deactivated this plugins and the issue disappeared.

Relevant Documentation:

Tagged: 

This topic contains 12 replies, has 2 voices.

Last updated by Carlos Rojas 6 months, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
March 29, 2019 at 11:14 am #3490625

Milos Mitrovic

I couldn't update your plugin for some time. Then your support helped me update it 2 days ago. Since then my website has been deformed. If I deactive the plugin it all comes back to normal.

Please help me with the problem.
Thanks

PS I cannot upload the printscreen of my website so please visit it.

March 29, 2019 at 11:58 am #3490959

Milos Mitrovic

Apparently you can't upload images through Microsoft Edge.

March 29, 2019 at 7:14 pm #3494219

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

March 30, 2019 at 9:54 am #3497697

Milos Mitrovic

Good Day Carlos,
Thank you for your prompt answer.

I do have a few issues to address here.

First of all, for some reason I can't backup my site. It's been backed-up a month ago, so I don't know if we can coninue here!? It seems I have to tick the 'I have backed up my site' box before we go on. What can I do?

Secondly, I don't know how to alter the config.php file. Just located it in Filezilla, but have no idea how to add something inside.

Thirdly, how do I know the information I share with you won't be seen by anybody else? How do I even know you are a member of WPML? My blog was hacked twice this month so I am really worried about sharing the access information with anyone.

Please let me know, so we can cpontinue resolving this problem.

Thanks,
Milos

March 30, 2019 at 6:36 pm #3499119

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Milos,
Thank you very much for your message.

I understand your concern and I will do my best to answer all of your questions.

1.- in teh case of the backup of the site, I recommend you to use the plugin All-In-One WP Migration, which is free and veary easy to use. You can download it from this link: https://wordpress.org/plugins/all-in-one-wp-migration/

In case this plugin doesn't work on your site I recommend you to contact your hosting providers and ask them for help, in this scenario they should be able to provide you with a solution.

2.- To edit the wp-config.php file you just need to open it -> Look for the line that says '/* That's all, stop editing! Happy blogging. */' -> Add the code provided right above this line -> Save the changes.

In case you still can't you can ask your hosting providers or, if you authorize me, I can do the changes once you provide access to the site.

3.- In this link you can read our support policy which describe how the information is managed by us: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Only our team has access to take tickets in this forum, you can double check our identities in the following links:
- https://wpml.org/forums/users/carlos-r/
- https://www.onthegosystems.com/team/

Please let me know if you need more information from my side and if you desire to proceed to debug this issue.

Best regards,
Carlos

March 30, 2019 at 6:58 pm #3499143

Milos Mitrovic

Hi Carlos,
Thank you for your reply.
Apparently my hosting provides complete backups once a day for the last 30 days. So, we are OK.
I can't edit the wp-config since it's not exactly the way it is inside the WordPress (no lines and numbers). My hosting company doesn't want to change it, they only offer the plan upgrade which Will include the higher php memory but for a higher cost. So I would prefer you change it,
I Will grant you an Access in a moment.
Milos

March 30, 2019 at 7:02 pm #3499151

Milos Mitrovic

So I don't know if I am replying now in a secure mode!? Yesterday there were some fileds I needed to check like for instance that I backuped the site completely. Now they are not here!
So, is this public or private?

Can you please let me know!

March 30, 2019 at 7:36 pm #3499253

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Milos,
Thank you very much for your feedback.

Your previous messages were public but I have set your next one private so you can provide access to the site in a secure way.

Looking forward to your message.
Regards,
Carlos

April 9, 2019 at 2:03 pm #3567673

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Milos,
Thank you very much for the information provided.

However, I tried to log in the site but the credentials are incorrect. Could you double check the credentials and edit your previous message if necessary?

Regards,
Carlos

April 9, 2019 at 2:50 pm #3568295

Milos Mitrovic

Can you try now?

April 9, 2019 at 5:24 pm #3569677

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Milos,

Yes, I was able to access the site this time. Thanks!

The cause of the issue is the Autoptimize plugin, I deactivated this plugins and the issue disappeared.

Could you confirm that the issue is solved?

Regards,
Carlos

April 9, 2019 at 7:57 pm #3570463

Milos Mitrovic

It Works correctly. The only thing is that my website is much slower now (since Autoptimize plugin is off). Do you have a good optimization plugin to recommend? I would highly appreciate it! Thanks for the great work!

April 9, 2019 at 8:05 pm #3570477

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Milos,
I'm glad to hear that the issue is solved 🙂

Please visit this link where you will find our Multilingual-Ready Plugins list: https://wpml.org/documentation/plugins-compatibility/

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos