Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Bruno Kos 8 months ago.

Assigned support staff: Bruno Kos.

Author Posts
March 28, 2019 at 3:16 pm #3482977

omniaT

Tell us what you are trying to do? see bellow

Is there any documentation that you are following? update via WP interface

Is there a similar example that we can see? No

What is the link to your site? hidden link (= production website)

Hi WPML Support,

We have a problem with the plugin 'WPML Multilingual CMS - Version 4.2.4.1. after updating. Before, we had version 4.1.4.
This is our production Home-page IMG-1.jpg, after updating 'WPML Multilingual CMS' (in our test enviroment) we have this IMG-2.jpg.

After searching, we found that there is a difference in how to displaying the blog posts. In production we have this IMG-3.jpg, and in test we found this IMG-4.jpg.
In production, I see after 'hentry' a category slug, afert updating there is no category slug any more. We use the slug on our home-page in a part that we have self made.
Maybe it's also not sure that this is the problem but after updating your plugin, we had this porb....

Can you give us some more info about your last changes? If you need more info form us, please ask me.

March 29, 2019 at 11:20 am #3490721

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Thank you for contacting WPML support!

Have you updated something else in the meantime, like theme, plugin or WordPress? You can see the changelog here:
https://wpml.org/download/wpml-multilingual-cms/?section=changelog

I am not sure if something was changed in that direction in the meanwhile.

We use the slug on our home-page in a part that we have self made.

Does it mean that you've custom-coded this, or?

Regards,
Bruno Kos

March 30, 2019 at 9:58 am #3497833

omniaT

Hi Bruno,

Yes we updated our Theme (Avada) and our other plugins. Everything was going well until I updated the WPML Multilingual CMS - Version 4.2.4.1. plugin.
We use the Avada Theme.
And yes, we made some plugins by ourselves.

Maybe I can start again from a backup and as first plugin, I update the WPML Multilingual CMS - Version 4.2.4.1. plugin, and see what happent.
I will discus this in my team.

Kind regards,
Veerle

March 30, 2019 at 11:12 am #3498049

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi Veerle,

WPML is not in charge of these elements - It would not remove or change this markup. So what comes to my mind is that some of the custom code you've created my have been affected with some of the WPML/theme/plugins updates and may need to be adjusted accordingly.

Regards,
Bruno Kos

April 3, 2019 at 3:06 pm #3527777

omniaT

Hi Bruno,

We still try to find the problem. We have disabled the WPML Multilingual CMS - Version 4.2.4.1. plugin and then our home page looks like this 'TestWebsiteZonderWPML.jpg'. When we enable the WPML plugin we have this 'TestWebsiteMetWPML.jpg'.

In the files you can see the difference. You can see it by 'hentry'.

- In the 'TestWebsiteZonderWPML - code.jpg' you can see the code when we disable WPML.
<article id="blog-1-post-9291" class="fusion-post-grid post-9291 post type-post status-publish format-standard hentry category-omnia-travel-search">

- In the 'TestWebsiteMetWPML - code.jpg' you can see the code when we enable WPML.
<article id="blog-1-post-9291" class="fusion-post-grid post-9291 post type-post status-publish format-standard hentry">

=> the category is gone.... The categories are translated in 3 languages.

Kind regards,
Veerle

April 4, 2019 at 11:02 am #3534211

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

I am not sure what is behind this - would you be interested testing this with the latest Avada (so not modified, but a parent theme as it is downloaded from their site), along with latest WPML on our testing clean sandbox server? If yes, let me know and I will prepare everything for you.

Regards,
Bruno Kos

April 4, 2019 at 3:30 pm #3536577

omniaT

Hi Bruno,

We have updated the WPML Multilingual CMS to version 4.2.5 (also the String Translation & Translation Management) and now it works again.
In the code you can see that there is something again after the 'hentry', see also in attachment.

<article id = "blog-1-post-9291" class = "fusion-post-grid post-9291 post type-post status-publication format-standard hentry category-omnia-travel-search" style = "position: absolute; left: 0%; top: 0px; ">

Please, can you give us an explanation. This is very important to us.

Kind regards,
Veerle

April 10, 2019 at 9:07 am #3573983

omniaT

Hello Bruno,

I have discussed this with our team and we are going to put back an back-up again on our test website and update again to the latest version of the WPML plugins and of Avada.
If the website is still ok, then it's good for us.
If not, I will contact you again.

Kind regards,
Veerle

April 10, 2019 at 10:09 am #3574719

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi Veerle,

Ok, sounds like a plan.

Regards,
Bruno Kos