This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Shekhar Bhandari 5 months, 2 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
April 27, 2019 at 11:46 am #3695321

Harold

I am trying to set up WPML on a wordpress multisite network, with the following features:

- SSL is enabled for each domain (three domains so far, each configured as a site in the main WP network)
- WPML is installed, but not yet configured. When it is configured I want each language for each site to point to the same domain. e.g. English & Chinese for hidden link both point to the same domain, hidden link (so can use url language strings)

We're having various issues with this. How do we get this to work?

April 29, 2019 at 11:18 am #3702577

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

I am sorry but I couldn't understand your requirement properly, so could you please let us know more about it?

Are you trying to have sites as below?
- multisite
-- site 1 as one language
-- site 2 as one language
-- site 3 as one language

Look forward to your reply.

Thanks

April 30, 2019 at 3:57 am #3707779

Harold

Hi Shekhar,

We have WordPress installed as a multisite network on a LEMP server, with three domains and SSL activated.

Each domain will contain unique content, and each site should have WPML multi-language support. i.e.:

Site 1:
hidden link - english language content
hidden link - simplified chinese content

Site 2:
hidden link - english language content
hidden link - simplified chinese content

Site 3:
hidden link - english language content
hidden link - simplified chinese content

Is this configuration supported? When SSL is activated, for the domains, WPML isn't loaded.

April 30, 2019 at 7:50 am #3708871

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Yes, this is supported. Did you network enabled the WPML plugin?

If the problem exists, To debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

May 3, 2019 at 5:04 am #3730867

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can see the plugin is installed properly, could you also help me replicate the issue by providing a step to step guide?

Look forward to your reply.

Thanks

May 3, 2019 at 10:28 am #3733145

Harold

Hi Shekhar,
Basically, WPML is installed and activated at the network admin level. For the primary site (xixspirit.com) WPML is active and appears to be functioning normally. For the other two sites (maltinchina.com & whiskydreams.co) it appears that WPML is 'enabled but not effective'. What does this mean?

May 3, 2019 at 10:45 am #3733283

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

You will need to run the WPML setup separately for these sites too. Could you please finish the setup using "Configure WPML" and let me know if this helps.

Look forward to your reply.

Thanks