This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 3 replies, has 3 voices.

Last updated by davidS-133 1 year ago.

Assigned support staff: Bruno.

Author Posts
October 3, 2018 at 8:25 am #2783918

davidS-133

I am trying to: click on the button in the notice with the title 'WPML needs to upgrade the post's media information.'

Link to a page where the issue can be seen: WP Dashboard hidden link

I expected to see: an ok notice that media information was updated

Instead, I got: nothing, the Network call in F12 throws an error: 400 Bad Request

We have tried this: https://wpml.org/forums/topic/wpml-needs-to-upgrade-the-posts-media-information/ but with no result.

I CAN give you access to WP (but not sftp/duplicator)

October 5, 2018 at 5:40 am #2789572

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

Please as a test, could you disable all non-WPML plugins and see if the problem persists?

Also, did you notice if any error messages are happening? Please, could you enable debug to see if any error message is displayed? To do it, please check the steps in our documentation: http://wpml.org/documentation/support/debugging-wpml/

Then try again to check the problem. If any error message appears, please paste here in the post for me to see.

Thank you.

October 5, 2018 at 5:43 am #2789573

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Have you still having the issue after deleting the wpml_notices key from *wp_options* table? Please do the following steps after a full site backup and make sure the issue is existing or not.

1) Go to your Database(using a took like PHPMyAdmin)
2) Choose wp_options table
3) Search for the key wpml_notices
4) Then remove it

If you are still having the issue, please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

October 15, 2018 at 6:21 am #2816328

davidS-133

Hi Bigul,

I've deleted the database entry with the 'option_name': 'wpml_notices' and now the problem is fixed.