Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.44 hours from now. Thank you for your understanding.

This topic contains 18 replies, has 2 voices.

Last updated by phamH 10 months ago.

Assigned support staff: Radu.

Author Posts
February 25, 2020 at 2:15 am #5558129

phamH

First at all, add 2 lines into your file host:
45.77.248.26 quanpham.vn
45.77.248.26 hidden link
WPML not working on my site except posts, products, product categories.

Header, Footer, Widget not working, new strings is marked "Translation is complete" not working.
Tell us what you are trying to do?
Remove old version WPML and install newest version.

Is there any documentation that you are following?
1. https://wpml.org/forums/topic/string-translations-not-working-only-works-when-connected-as-admin/
2.
❌ Before proceeding please make a full website backup! ❌

- Go to WPML -> Support Troubleshooting
- Press the following buttons:
- "Clear the cache in WPML"
- "Remove ghost entries from the translation tables"
- "Fix element_type collation"
- "Assign translation status to duplicated content"
- "Set language information"
- "Fix terms count"
- "Fix post type assignment for translations"

Is there a similar example that we can see?
Look at attach pictures

What is the link to your site? quanpham.vn
First at all, add 2 lines into your file host:
45.77.248.26 quanpham.vn
45.77.248.26 hidden link

February 27, 2020 at 4:29 am #5575699

phamH

Who can help me?

February 27, 2020 at 11:16 am #5577371

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey,

I tried to add the two entries to the hosts file but once I do this, I get this privary error: NET::ERR_CERT_COMMON_NAME_INVALID. If I have no entry on the hosts file from your website, I see the strings as in the attached screenshots.

As I can see, the string is working fine in Vietnamese and needs to be tranlated in English. Can you tell me if you changed anything in the meantime, please?

Last but not least, could you give me access to the dashboard area so I can have a look at the settings too, please?

Thanks,
Radu

February 28, 2020 at 5:00 am #5582851

phamH

<quote>I tried to add the two entries to the hosts file but once I do this, I get this privary error: NET::ERR_CERT_COMMON_NAME_INVALID. If I have no entry on the hosts file from your website, I see the strings as in the attached screenshots.</quote>

Just add 2 lines into your file host, use Firefox browers and delete all cache, history.
45.77.248.26 quanpham.vn
45.77.248.26 hidden link

March 2, 2020 at 2:36 pm #5600229

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey,

I tried to add these values to the hosts file but I still see that warning about the certificate. I get the same message in Chrome, Firefox, and Safari.
I get this warning only when I add the values to the hosts file.

Can you check this out and get fixed this certificate issue, please? Once it's fixed, I'll have a look at the string in no time.

Thanks,
Radu

March 3, 2020 at 1:57 am #5603457

phamH

Hi Radu,

Try follow links:
1. hidden link
2. hidden link
3. hidden link

Add into file host:
45.77.248.26 quanpham.vn
45.77.248.26 hidden link
45.77.248.26 hidden link
45.77.248.26 hidden link

Try login admin with information private message.

If you can't access website by this way, close topic, I will open new post.

Thanks for your help, Radu.
Have a nice day.

March 4, 2020 at 3:08 am #5612323

phamH

Note: Use Private Window (Ctrl + Shift + P) Firefox to login admin Dashboard.

March 4, 2020 at 6:11 am #5613007

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey,

Can you tell me if you made any changes in the meantime? I was able to access the dashboard area yesterday but now I am redirected to hidden link.

If I try to use the private window, as you mentioned in your previous message, I get again that message about the invalid certificate, which wasn't happening yesterday.

Thanks,
Radu

March 4, 2020 at 7:43 am #5613387

phamH

Hi Radu,

Im reinstall site, please try again.
Note: Use Private Window (Ctrl + Shift + P) Firefox to login admin Dashboard.

March 6, 2020 at 9:24 am #5633239

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Pham,

I was able to check the website now. I could see that the Porto theme options are saved a bit different and this might be the reason why this is not working.

Also, I can see that the theme that you're using (Porto) is not a part of the WPML compatible themes list (https://wpml.org/documentation/theme-compatibility/) so there still might be some issues when using with WPML (like this one).

The theme seems to be using some transients to save the options. This might be a problem because the text from the top is not loaded from WPML, it's loaded from the transients. Can you try to reach out to the theme authors and ask them to have a look at this, please? You can try to ask if there's an option to stop the transients. I looked at the theme options but couldn't find anything about this.

Also, you can ask them to apply for the Go Global program (https://wpml.org/documentation/theme-compatibility/go-global-program/). This way, they will work with our compatibility team and make sure that everything works very well between the Porto theme and WPML.

Thanks,
Radu

March 7, 2020 at 3:17 am #5638477

phamH

Hey Radu,
This theme (Porto) is Compatible with WPML plugin, see more:
hidden link

I'll try to use another plugin.

Thanks for your help.

March 9, 2020 at 2:03 am #5644127

phamH

Hi Radu,

I did it.

March 9, 2020 at 5:28 am #5645323

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Pham,

I just tried to translate the string from the top of the page the same way I tried to do it on your website (through WPML → String translation), and everything worked fine. You can have a look here:

hidden link

In this case, I think that some sort of cache might be causing the translation to not be displayed fine. Is there any chance that you could activate back the WPML plugin on your website so I can have another look at this, please?

Thanks,
Radu

March 9, 2020 at 9:31 am #5646391

phamH

Hi Radu,

Please reinstall WPML plugin on my site again.

Don't forget: Use Private Window (Ctrl + Shift + P) Firefox to login admin Dashboard.

Thank you.

March 11, 2020 at 2:01 am #5658441

phamH

Hey,

Migration Failed

I dont know why. Can you do it? Or I give you my SFTP information?