This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: WPML is not compatible with "Visual Composer Site Builder" Solution: We are fully compatible with the "WPBakery" Page Builder", but unfortunately not yet with the "Visual Composer Website Builder".

Visual Composer was formerly the Page Builder, now the name is used for the "Site Builder". Please see the following video to see the differences: https://visualcomposer.com/help/faq/visual-composer-website-builder-vs-wpbakery-page-builder/

Relevant Documentation: https://wpml.org/forums/topic/visual-composer-website-builder-compatibility-not -wpbakery-page-builder /

This topic contains 4 replies, has 2 voices.

Last updated by johannaN-2 6 months, 2 weeks ago.

Assigned support staff: Marcel.

Author Posts
March 20, 2019 at 8:05 am #3385829

johannaN-2

I am trying to: Translate this website where visual composer is installed and updated

Link to a page where the issue can be seen: wp.brockytony.de

I expected to see: The translated text when switching language

Instead, I got: A buggy version, just look at it (language switcher top right corner)

I used WPML on other sites and had no problems yet - side fact: those sites used a theme version of visual composer (vc) and vc didn't update there.
On this website now there is the latest version of visual composer installed and they dropped the backend editor. So I'm working with the WPML advanced translation editor. And this seems to not work.

How to fix this issue?

March 20, 2019 at 6:41 pm #3392589

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Johanna,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Ich müsste mir das bitte im Backend ansehen.

#1 Ich bräuchte bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

#2 Könnten Sie bitte auch das WordPress Memory Limit erhöhen? Sie müssen dazu folgenden Code in Ihre wp-config.php hinzufügen:

define ('WP_MEMORY_LIMIT', '256M'));

Freundliche Grüße
Marcel

April 1, 2019 at 5:18 pm #3510345

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Felix,

ich habe mir nun alles angesehen, eine XML Konfig erstellt, Visual Composer aktualisiert, jedoch bekomme ich die Elemente mit beiden WPML Editoren (Klassisch und Advanced) nicht zum Laufen. Ich schaue mir morgen einen anderen Workaround für Ihre Seite an.

Bitte daher noch um etwas Geduld

Freundliche Grüße
Marcel

April 2, 2019 at 4:53 pm #3519249

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Felix,

wie Sie vielleicht mitbekommen haben wurde der Page Builder "Visual Composer" zu "WPBakery" umbenannt.

-> "WPBakery" ist nun der Content Page Builder,
-> "Visual Composer Website Builder" nun der neue Frontend Editor, welcher auch Header & Footer Gestaltungsmöglichkeiten bietet.

Wir sind voll mit dem "WPBakery Plugin" kompatibel, leider noch nicht mit dem von Ihnen eingesetzten "Visual Composer Website Builder", siehe https://wpml.org/forums/topic/visual-composer-website-builder-compatibility-not-wpbakery-page-builder/

Der Hersteller dieses Plugins hat extra ein Video wegen dieser Verwirrung aufgenommen: hidden link

Am besten kontaktieren Sie Visual Composer als Plugin Hersteller, ob hier weitere Tätigkeiten geplant es mit WPML zu integrieren, da von uns bereits Arbeiten dazu gemacht wurden.

Ich empfehle ich Ihnen daher, wenn möglich das Theme zu wechseln sowie WPBakery einzusetzen.

Freundliche Grüße
Marcel

April 3, 2019 at 6:40 am #3522841

johannaN-2

Hallo Marcel,

vielen Dank für deine Bemühungen!
Wir können leider das Theme zum jetzigen Zeitpunkt nicht mehr wechseln.

Da es sich quasi um (fast) einen Onepager handelt, werden wir versuchen die Seite zu duplizieren und die englischen Seitenaufrufe auf die englische Seite weiterzuleiten.

Hoffentlich kommt trotzdem noch ein Update, dann können wir auf diese Notlösung verzichten ;D

Nochmals danke und freundliche Grüße
Felix Baumgärtner