This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 3 voices.

Last updated by martynS 2 months ago.

Assigned support staff: Andreas W..

Author Posts
August 7, 2019 at 7:24 am #4352453

alexanderM-23

I am trying to:
Translate pages using cornerstone.
I don't want to copy any contents, but the translations have to be connected.

Unfortunately WPML replaces the content of a translated page with the default language content. If I disconnect the pages and save content with cornerstone. It shows up.

How do I translate cornerstone pages completely independent, but still mark them as translations of each other?

Link to a page where the issue can be seen:

I expected to see:
The translated version of the page

Instead, I got:
The default language of the page.

August 7, 2019 at 6:44 pm #4357511

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

One option here is to set the Cornerstone post types to "translatable - fallback to default language" - this will allow to visualize default language content on other language pages, in case a translation does not exist.

As far I understood you do wosh to use different content but you do not wish to translate with the WPML Translation Editor?

In order to translate manually you can duplicate the orignal content as translation and then edit the translations manually. It is important to first duplicate the original pages as this will make sure that the Cornerstone page layout and content will be copied.

In the right sidebar of your page editor go to Languages and mark the checkbox for "Duplicate" and apply the content.
Now, swtich the language on the top admin bar and zou should see the page editor for zour translated page. A popup should show up where you will need to select "Edit anzways".

Also, in the Language setting on the right sidebar you will find a button asking if you wish to "Translate independently". Mark it in oder to undo the connectivity between translated contents.

Now, deactivate the WPML Translation Editor inside of the same Language options. Set it to "off" and select "all page" in the popup. This way the default WordPress Editor will show up for all page translations.

Relative documentations:
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/

https://wpml.org/documentation/theme-compatibility/xtheme/

Let me know if you need anz assistance here and I will set this up for you.

Kind regards
Andreas

August 9, 2019 at 12:32 pm #4370263

alexanderM-23

Hi,

unfortunately this is not possible.

I can add a translation as a copy of the original, set to edit independently.

Then I am able to use cornerstone editor to update the translation as I wish.

The problem is, when I hit "save" the original language still overrides the content. :/

August 10, 2019 at 12:24 am #4373277

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for the clarification.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

August 12, 2019 at 4:11 pm #4382225

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

I have revised the demo page and I realised that after creating a Cornerstone page the text block is not available on the WPML Translation Editor.

On the other hand, when disabling the WPML Translation Editor I am able to edit each page manually without affecting each other. The WPML Translation Editor can be disabled on the page editor in the right sidebar. (See screenshot)

Now, as far I understood you want to have the pages connected but they should show different content, correct? In this case disabling the WPML Translation Editor would be the correct way. This way the pages will stay connected and can be edited indepentently. Further it assures that the language switcher will guide the user to the matching content in different langauge.

Could you please have a look at the created test page "WPML Test". I have disabled the WPML Translation Editor and there is not any issue so far bz editing each page manually using the WordPress page editor.

The fact that the cornerstone content is not showing up on the WPML Translation Editor surely is not expected. I will need to investigate further about this issue and would like to ask you to install the X Theme and Cornerstone on the following test site in order to escalate the issue to our compatilbity team.

One Click Login: hidden link

Leave me a short notification once the theme and plugin are installed.

Kind regards
Andreas

August 12, 2019 at 8:39 pm #4383561

alexanderM-23

Hi,

so I tried to reproduce what you did on the live website.
But the behaviour persistet (as I tried this before and it didn't work).

So, had a look on the Plugin directory => you diabled "WPML Media".

I also disabled "WPML Media" on the live website and everything works as expected.

I believe this is a bug in "WPML Media" which should ne resolved.

Regards,

Alex

August 15, 2019 at 6:13 pm #4402919

martynS

We're also seeing this issue and disabling WPML Media plugin fixed it. Thing is, we actually use WPML Media so this isn't really an option for us. Is this issue being picked up in a separate ticket? Because this one is marked as resolved.