Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by Vincenzo 2 years, 4 months ago.

Assigned support staff: Vincenzo.

Author Posts
July 20, 2017 at 3:17 pm #1323802

ali iqbal

I am trying to: translate the pages that i create in page builder. not working, when i open the page to translate, in the body area, only the code displays.

Link to my site: arabbaba.com

I expected to see: i expected as shown in your guide video

July 20, 2017 at 4:26 pm #1323871

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello, thank you for contacting WPML Support!
I will take care of your ticket.

Can you please tell me if you are using standard Visual Composer shortcodes or some custom shortcodes added by the theme?
Here you can find a list of the standard Visual Composer shortcodes, supported by WPML:
- https://wpml.org/documentation/plugins-compatibility/visual-composer/

If you are using custom shortcodes, you can try adding them to the wpml-config.xml file or ask the theme author to do it as explained here:
- https://wpml.org/documentation/support/wpml-integration-with-page-builders-that-use-shortcodes/

If you are unsure about this, you can post the unrecognized shortcodes here:

Alternatively, you can try disabling the Translation editor from WPML -> Translation Management -> Multilingual Content Setup

Thank you

July 20, 2017 at 4:28 pm #1323876

ali iqbal

if i disable the translation editor then how will i translate the pages of my theme.

July 20, 2017 at 4:43 pm #1323889

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

once the Translation editor is disabled you can manually translate the pages as it was done before the introduction of the WPML integration with page builders that use shortcodes.

But this is just an alternative to be used if we are not able to solve the issue.
Before doing this, can you please try the other options?

Thank you

July 20, 2017 at 4:48 pm #1323898

ali iqbal

no i cannot use naother option as it will cost me more and more.
please if you can do something, i just have two days, after it i have to refund this service from wpml.

July 20, 2017 at 4:50 pm #1323900

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

*Important: Be sure to backup your site and database first before you proceed!

✙ I would additionally need your permission to de- and re-activate Plugins and the Theme, and to change configurations on the site.
This is also a reason the backup is really important.

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

July 22, 2017 at 7:12 am #1324902

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

I did not receive the credentials and this is the first answer I get from you since I asked for credentials.

I will activate another private answer.

I would like to request temporary access (wp-admin and FTP) to your test site to take a better look at the issue.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

*Important: Be sure to backup your site and database first before you proceed!

✙ I would additionally need your permission to de- and re-activate Plugins and the Theme, and to change configurations on the site.
This is also a reason the backup is really important.

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you

July 22, 2017 at 7:19 am #1324905

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

I did receive the credentials but I am not able to log in because the front end and the backend pages return an HTTP ERROR 500.

Can you please check this and let me know when the page is accessible again?

Thank you

July 22, 2017 at 7:26 am #1324907

ali iqbal

yes i add some lines in wp-config files for increasing the php memory limit. please check now.

July 22, 2017 at 7:37 am #1324910

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

I was able to access the website.

I will keep you informed.

Thank you for your patience.

July 22, 2017 at 8:37 am #1324929

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

I checked the page that you are trying to translate. The issue is caused by the use of custom shortcodes. These shortcodes are not supported by WPML.

There are 2 alternatives to solve this:

1. You can try adding these shortcodes to the wpml-config.xml file or ask the theme author to do it as explained here:
- https://wpml.org/documentation/support/wpml-integration-with-page-builders-that-use-shortcodes/

2. Create translations manually.

As a test, I temporarily enabled the manual translation system from WPML -> Translation Management -> Multilingual Content Setup -> How to translate posts and pages.

Can you please try to manually translate the "Magazine simple style — Front Page"?
- Is this a good translation method for your needs?
- https://wpml.org/documentation/translating-your-contents/creating-translations-manually/

If you prefer using the translation editor then I will re-enable it and I will show you how to register the shortcodes used in the front page.
- You can ask the theme author to register all the other custom shortcodes or you can add them yourself following the examples.

Please let me know your decision.

Thank you

July 22, 2017 at 1:20 pm #1324995

ali iqbal

when i translate it manually, the body area shows only the codes and i dont know how to translate them. your guide is showing something very easy with the page builders

July 22, 2017 at 1:56 pm #1325006

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

please remember that the cause of the issue is that the shortcodes used on your page are not supported by WPML because they are custom shortcodes added by the theme.
This is why it is not possible to use the Translation editor at the moment.

When you translate manually, you should see the same interface of the page in the original language. You just need to press the "Copy content from [original] language" button and you can start translating the page in the same way that you created the original page.
See attached screenshots:

1. Can you please post a screenshot of what you are seeing?

2. Please post a detailed list of the steps that you perform to translate a new post/page.

3. Have you tried to translate the "Magazine simple style — Front Page"?

Thank you

July 22, 2017 at 2:04 pm #1325009

ali iqbal

this is the interface i am watching right now and i attached the screenshot, i did not click on copy content from english, and as you see in the screenshot it is disabled.
and the drop down in which the arabic is displaying is also disabled.

July 22, 2017 at 2:10 pm #1325012

ali iqbal

ok i see the screenshots just right now. please wait i try.