Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 1 reply, has 2 voices.

Last updated by Mateus Getulio 3 months, 2 weeks ago.

Assigned support staff: Mateus Getulio.

Author Posts
October 6, 2021 at 5:51 am #9728965

Anna Pantelakaki

We are building a two language site with a custom theme developed by us

We have observed that when we are installing wpml the performance score drops drammaticaly,
Because we are aiming at high performance we want you to suggest to us, a server that will be eligible to get a high performance with your plugin or some settings that we can avoid in order our site to be as fast as it can be.

Awaiting for your answer as soon as possible

Best Regards
Anna

October 7, 2021 at 12:18 pm #9741007

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Anna,

Welcome to the WPML support forum. I'll be glad to help you!

There are some measures that we can take in order to improve the performance of a website running with WPML. First, depending on how many strings your site has, this can impact performance a little bit. As a suggestion, disable automatic string indexing. To do this, please follow the steps below:

- Click on the WPML -> String Translation
- Scroll down and enable the "Auto register strings for translation" option
- Click on the "Edit" button
- Uncheck all strings which you do not want to be automatically indexed
- Click on the "Apply" button

Following the above steps, is the problem solved? Please remember to uncheck the "Auto register strings for translation" option after you're done.

Furthermore, have you read our documentation on how to optimize your site? Please check it out:
https://wpml.org/2012/01/can-your-site-run-faster/
http://wpml.org/faq/how-to-optimize-mysql-queries
http://wpml.org/faq/why-string-translation-appears-to-slow-down-sites/

Another attempt that you can try is to go to WPML -> Languages -> Make themes work multilingual and disable the "Adjust IDs for multilingual functionality" option. With this enabled, load times are higher.

Give those solutions a try and let me know if they help you. We're looking forward to your reply. Thank you!

Kind regards,
Mateus.