Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Mihai Apetrei 2 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
July 19, 2021 at 7:29 pm #9232619

flavioM-10

Hi there, I'm not being able to update WPMLin our registered sites. We have an WPML Multilingual CMS account, whose next renewal date is only on 2022-09-07, and only 2 sites registered with it: hidden link and hidden link.

However, when I try to update WMPL or any of its modules in the Plugins page of the sites, the message "WPML plugin cannot connect to wpml.org" is displayed at the top. All other plugins and the theme used in those sites are being updated normally. Could you please fix that?

download.png
July 20, 2021 at 7:38 pm #9239691

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there.

If WPML is already registered, what is showing up at the top might be a false positive, related to some cached information that still exists.

This issue might be cache-related (please take a look at the steps recommended by my colleague in the ticket below):
https://wpml.org/forums/topic/wpml-plugin-cannot-connect-to-wpml-org-9/

I also suggest to first go to WPML > Support > Troubleshooting > and clear the WPML cache. Then see if the issue is resolved.

You can also try this:
https://wpml.org/forums/topic/wpml-plugin-cannot-connect-to-wpml-org-29/#post-9068077

If it's not, you can also try to see if the hosting that the website lives on has any caching that needs to be cleared. You can even ask the Support department of the hosting company the website lives on and see if they can clear the cache for you.

Sometimes, this issue can also be related to some specific settings on the server.

Please take a look here (https://wpml.org/forums/topic/wpml-plugin-cannot-connect-to-wpml-5/#post-8107577) and see if that helps.

There are also a good amount of ticket results in the custom link that I created below for you where you might find a solution for your situation:
hidden link..69i57j69i58.3405j0j7&sourceid=chrome&ie=UTF-8

Please let me know if the issue is still happening after you try those steps.

Kind regards,
Mihai Apetrei

July 21, 2021 at 2:34 pm #9246013

flavioM-10

Hi Mihai,

I believe I tried all the suggested steps, including flushing the cache on the server (Flywheel), switching to Development mode (Flywheel), deactivating our Defender security plugin, clearing the cache on WPML. All the other plugins update, except WPML. Still the same problem...

July 22, 2021 at 11:41 am #9252331

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the confirmation.

Can you please try this, too (let's see if after the manual-update process, the notice still shows up):

  • create a full website backup
  • download the latest version of the WPML plugins from https://wpml.org/account/downloads/;
  • disable WPML Multilingual CMS and the other active WPML plugins
  • delete WPML Multilingual CMS and the other WPML plugins (the settings and the translations are saved in the database so they will not be deleted);
  • upload the freshly downloaded WPML plugins from Plugins → Add New → Upload Plugin
    → Activate the plugins one by one, main WPML plugin first
    ;

Please let me know if the notice is still showing up (make sure that WPML is still registered - you can check this in Plugins > Add new > Commercial).

Kind regards,
Mihai