Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Mihai Apetrei 2 months, 1 week ago.

Assigned support staff: Mihai Apetrei.

Author Posts
July 18, 2021 at 7:47 pm #9225439

marwanA-5

Hello there, I'm facing the following issue:

WPML plugin cannot connect to wpml.org

WPML needs to connect to its server to check for new releases and security updates. Something in the network or security settings is preventing this.

Please allow outgoing communication to wpml.org to remove this notice.

Can you help me on this please

July 19, 2021 at 10:55 am #9228873

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there.

If WPML is already registered, what is showing up at the top might be a false positive, related to some cached information that still exists.

This issue might be cache-related (please take a look at the steps recommended by my colleague in the ticket below):
https://wpml.org/forums/topic/wpml-plugin-cannot-connect-to-wpml-org-9/

I also suggest to first go to WPML > Support > Troubleshooting > and clear the WPML cache. Then see if the issue is resolved.

You can also try this:
https://wpml.org/forums/topic/wpml-plugin-cannot-connect-to-wpml-org-29/#post-9068077

If it's not, you can also try to see if the hosting that the website lives on has any caching that needs to be cleared. You can even ask the Support department of the hosting company the website lives on and see if they can clear the cache for you.

Sometimes, this issue can also be related to some specific settings on the server.

Please take a look here (https://wpml.org/forums/topic/wpml-plugin-cannot-connect-to-wpml-5/#post-8107577) and see if that helps.

There are also a good amount of ticket results in the custom link that I created below for you where you might find a solution for your situation:
hidden link..69i57j69i58.3405j0j7&sourceid=chrome&ie=UTF-8

Please let us know if the issue is still happening after you try those steps.

Kind regards,
Mihai Apetrei