This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The sitepress map is in the HTML Wordpress plugin map route visible but not in the wordpress dashboard or plugin's

Solution: - Copy the plugins files in the site's plugin folder via FTP. - Create a full backup of the site. - Go to Dashboard -> Updates -> Click on 'Re-install Now' button to re-install WordPress core. - Go to Plugins -> Activate 'WPML Multilingual CMS' plugin.

Relevant Documentation:

This topic contains 15 replies, has 2 voices.

Last updated by Carlos Rojas 1 year ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 26, 2018 at 7:56 am #2766267

frankB-29

I am trying to: use the wmpl plugin as worked and config before

Link to a page where the issue can be seen: you only can see there isn't any translation (management) anymore on the website

I expected to see: the wpml plugin working

Instead, I got: nothing! And hopefully no issues by resolving this like al the (translation and config) work I already done

Notice: I confirmed for the advanced wpml yesterday and the sitepress map is in the htlm wordpress plugin map route visible but not in the wordpress dashboard or plugin's

September 27, 2018 at 12:10 am #2768886

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

Have you tried to manually copy the plugins files in the site?
You can download the files from this link: https://wpml.org/account/downloads/

Kind regards,
Carlos

September 27, 2018 at 9:03 am #2769845

frankB-29

Hi Carlos, tnx for reply.

I tried to upload the zip file but the name of the map in plugins does already exist. I've checked and the map and files are still there. But not visible in the wordpress plugin and menu dashboard. Or do you mean to copy files one by one in the plugin map and submaps? I don't know that works and will did effect my translated work I've already done? I can give you access if needed so.

Sincerly,
Frank

September 27, 2018 at 9:23 am #2769959

frankB-29

By the way I assigned for WPML advanced (don't know if this is related to this issue/bug but in time is could be related after this update this issue appeared). And still can't get back to the dashboard for adding translator(s) the landingspage after I confirmed for the advance wpml. Please help!

September 27, 2018 at 6:58 pm #2771611

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

September 28, 2018 at 2:25 pm #2774217

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Frank,
Thank yo very much for the information provided.

I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Best regards,
Carlos

October 1, 2018 at 9:30 am #2777574

frankB-29

Hi Carlos, I've did what you asked me too but still no recovery or something like that. De-activated all plugins without the wmpl related and activated another theme (seventeen) the wpml aka sitepress-multilangual-cms didn't show up as plugin neither the translated text or content became visible at the front-end. If I shall delete the sitepress-multilangual-cms map from plugins will this also delete all translated concent of is it posibble to upload the map again with preservation of the translations?

Please help!

Notice the wpml worked fine with the installed plugin's. Doesn't this has anything to do with the signup for the wplm advanced? I already can't get back to the landingspage after the confimation button in the activation email from wpml and still haven't activated translators.

October 1, 2018 at 7:06 pm #2779239

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Frank,
Thank you very much for your feedback.

I would like to ask your authorization to create a copy of the site in order to make further tests in a local environment without affecting the live site.

Looking forwad to your answer.
Best regards,
Carlos

October 2, 2018 at 10:30 am #2781117

frankB-29

Hi Carlos,

Ofcourse that's not a problem. I give you the authorization (already did with the login credentials for wordpress and ftp). I hope this works out into an positive solution.

Sincerly,
Frank

October 2, 2018 at 6:03 pm #2782441

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Frank,
Thank you very much for your authorization.

I would like to ask you to follow this steps:
- Create a full backup of the site.
- Go to Dashboard -> Updates -> Click on 'Re-install Now' button to re-install WordPress core.
- Go to Plugins -> Activate 'WPML Multilingual CMS' plugin.

Could you tell me if the issue is solved?

Regards,
Carlos

October 3, 2018 at 11:16 am #2784326

frankB-29

Hi Carlos,

Just did it unfortunately I did not see WPML Multilingual CMS (but still have wpml string and wpml translation management running) and not the fundamental wpml plugin (named at the wp-plugin map as 'sitepress multilingual cms').

Getting a bit desperated... hope you can find a way through this issue.

Regards,
Frank

October 3, 2018 at 6:04 pm #2785444

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Frank,

I would like to ask your authorization to make this steps myself in the live site and compare the results with the copy on local.

Looking forward to your answer.
Best regards,
Carlos

October 3, 2018 at 7:55 pm #2785619

frankB-29

Hi Carlos,

No problem you’ve got my permission to do so. Hope this works and tnx in advance.

Sincerly,
Frank

October 3, 2018 at 8:45 pm #2785743

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Frank,

Now you can see the plugin. Could you confirm that the issue is solved?

Regards,
Carlos

October 4, 2018 at 7:37 am #2786561

frankB-29

My issue is resolved now. Thank you!