This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Bruno Kos 2 months ago.

Assigned support staff: Bruno Kos.

Author Posts
August 14, 2019 at 7:48 am

hiltonM

I am trying to: We have a website with 2 translations - English and Afrikaans. It has been fully translated already. If we try to edit any text using Elementor it just offers a 503 server unrepsonsive error. I have changed themes, and disabled all plugins and found the culprit is as soon as WPML is enabled.

Link to a page where the issue can be seen: hidden link

I expected to see: The updates saving.

Instead, I got: 503 server not responsive on Elementor update after taking forever.

August 14, 2019 at 9:20 am
August 14, 2019 at 9:20 am #4393703

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I will reply here from now on!

Regards,
Bruno Kos

August 14, 2019 at 9:44 am #4393777

hiltonM

Looking forward to it being resolved

August 14, 2019 at 1:04 pm #4395001

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you tell me if it makes a difference if you disable mod_security on your server?
hidden link

Regards,
Bruno Kos

August 14, 2019 at 1:15 pm #4395031

hiltonM

Hi there,

Sadly we are on a dedicated server with Xneelo (Hetzner) and are not able to disable mod_security.

I have also noticed that I can save the page as a template - import it into another page - and that works - but then I will need to redo all of my translations.

August 19, 2019 at 6:10 am #4413655

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I see - I have tried the following within my .htaccess file and it seems to be saving, even though slower then when WPML is active, however not nearly as slow as without this.

I tried this:

<IfModule mod_security.c>
  SecFilterEngine Off
  SecFilterScanPOST Off
</IfModule>

I followed this answer for this:
https://stackoverflow.com/questions/12928360/how-can-i-disable-mod-security-in-htaccess-file/12928404#12928404

However, I've also asked our 2nd tier if there's anything else we can try here - I will keep you posted if there are any other suggestions we could try.

Regards,
Bruno Kos

The topic ‘[Closed] WPML prevents updating of Elementor – causes 503 on page update.’ is closed to new replies.