This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The Grandium theme from Ninethemes is made suitable for WPML, but there's several problems. In pages, there's only a small part of all texts in the translate window -all main items are not showing.

In the theme there's a section called rooms items, where I switched the translation on, but there's parts, which cannot be translated, such as _blank, h, etc

Solution: The missing fields for this page are custom fields and you need to follow the steps described in this link to translate them: https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

This teme is adding custom Visual composer elements (shortcodes) and custom fields that doesn't have a proper language configuration file for WPML to map them.

Relevant Documentation: https://wpml.org/documentation/support/language-configuration-files/

This topic contains 19 replies, has 2 voices.

Last updated by Carlos Rojas 3 months, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
June 27, 2019 at 1:39 pm #4100449

jussiL

The Grandium support asked me to contact with WPML support.

The site is there: hidden link

The Grandium theme from Ninethemes is made suitable for WPML, but there's several problems. In pages, there's only a small part of all texts in the translate window -all main items are not showing.

In the theme there's a section called rooms items, where I switched the translation on, but there's parts, which cannot be translated, such as _blank, h, etc

How we can get this working?

Here's a couple of screenshots about this. The Norrby Gård page is the frontpage of the site, and You see there's much more to translate.

We have this WPML in other sites, but they don't behave like this.

Best Regards,

Jussi Leppänen

June 27, 2019 at 3:33 pm #4101341

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello Jussi,
Thank you for contacting WPML support.

1.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

July 2, 2019 at 10:35 am #4125775

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Jussi,

I made a small change in the front page and save it, which refreshed the entry in the database for this page. Now you can see the right text in the Advance Translation Editor (see attached image).

Could you confirm that the issue is solved?

Note: I increased the memory limit already 🙂

Regards,
Carlos

July 2, 2019 at 6:51 pm #4129545

jussiL

No, sorry, nothing has changed...I also don't found the attachment form Your message.

After I click the language editor switch from the pages tab, it opens the Advanced Translation Editor, but most of texts does not exist. Same happens when I open the translation editor from the rooms tab.

Can it be some kind of issue with Safari?

BR;

Jussi Leppänen

July 2, 2019 at 6:53 pm #4129561

jussiL

No it's not Safari related problem, I opened the edit with lates Firefox, and the issue is same with it.

July 2, 2019 at 7:00 pm #4129585

jussiL

Just found that the only text which the WPML shows are the Call to Action module. All the others are not showing in the front-page. Home Slider, Features Grid, About and Big Carousel gallery are modules of this theme, and all of them shoes no translation. Only the latest module (Call to Action) shows texts for translation. See attached image.

BR, Jussi

July 2, 2019 at 7:30 pm #4129727

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Jussi,
Thank you very much for your messages.

This time I took a deeper look at the issue and realize that the page is using custom shortcodes, not regular shortcode from Visual Composer.

I went to WPML -> Settings -> Custom XML Configuration and added the necessary code for WPML to map this shortcodes.

I recommend you to visit this link where you will find our official documentation on Language Configuration Files: https://wpml.org/documentation/support/language-configuration-files/

Could you confirm that the issue is solved?

Regards,
Carlos

July 2, 2019 at 7:35 pm #4129779

jussiL

Made also that found, that these items, which are not working are mostly WPBakery Page Builder items -their's content simply do not show in the Advanced Translation Editor.

In the Rooms editor, there's still these metadata words, which cannot be translated. permalink, -blank, h, s and so on.

BR, JL

July 2, 2019 at 7:44 pm #4129865

jussiL

OK, this is a long document, I'll check that. The translator shows more content now. I'll try the translation tomorrow, it's now 22.23 here in Finland 🙂

July 3, 2019 at 9:06 am #4133713

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Jussi,

I will be waiting for your message.

Regards,
Carlos

July 3, 2019 at 10:26 am #4134829

jussiL

Yess, we have still several problems here.

Frontpage We have made all translations to Sweden, it's 100% complete, but the page does not show

Next page is accommodation (Finnish Majoitus) and there are only headline available for translation:
hidden link

This page has has a rooms module, which collects all rooms items. There's one room item translated to Swedish, But it does not show.
This item has couple of odd text in the translation list:
hidden link

3. page is muut tilat, theres only a headline available for translation
hidden link

4. page is activities (aktiviteetit on Finnish) theres also only headline available for translation:
hidden link

5. is history page, and there is about all texts available for translation. In this page theres no special modules from this theme

6. page is contact page and again only the headline is available
hidden link

So all these WPBakery items in this theme are mostly disappeared from translation window

And even those Swedish translated pages which are 100% translated are not showing.

Best Regards

Jussi Leppänen

July 3, 2019 at 10:59 am #4135165

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Jussi,
Thank you very much for your message.

1.- I re-saved the translation of the frontpage and now it seems to be shown correctly. (Please notice that I don't speak any of these languages so it will be next to impossible for me to realize if there are untranslated text in the Swedish version, if you see some please let me know).

2.- For Accommodation page (Finnish Majoitus) I added the XML for the shortcode, now you can translate the content of the page in the Advance Translation Editor.

3.- For Muut tilat page I did the same than the previous page.

4.- In the case of the Aktiviteetit page I added the code but it seems that the best way to translate this shortcode is manually. To translate this page manually you need to change the language in the admin menu at the top of the page -> Click on 'Edit anyway' button and add the content.

5.- In Historia page you only need to translate it and save the changes.

6.- I added the code needed to translate the contact page, however, like the Aktiviteetit page the best way to translate this page is by doing it manually.

Please let me know the result of this changes.

Also, keep in mind that this shortcodes/elements don't come by default with Visual Composer but they are created by the theme or a third party plugin, that's why I recommend you to contact the authors and ask them to visit this link: https://wpml.org/documentation/support/language-configuration-files/ where they will find the steps to follow in order to make this completely compatible with WPML.

Best regards,
Carlos

July 3, 2019 at 11:05 am #4135243

jussiL

How come the advanced translator looks different than in Your tutorials page?

https://wpml.org/documentation/translating-your-contents/page-builders/#translating-page-builder-contents

There I can see all the styling options in the translator, but in our site there's none, it has only simple small boxes where to put the translated text. Usually text is also cut to boxes with only one sentence. How can we put text links in to the translation?

July 3, 2019 at 11:20 am #4135365

jussiL

I checked the majoitus (accommodation) page and the translator shows like You see in the screenshot. Only small part of the texts are available for translation, and there's also some kind of code in the translation window to be translated.

The original page is this:
hidden link

Again most of texts are missing, is there some kind of set up thing or something we have missed? Or is the problem with this theme? I have used WPML in other projects, but this one is quite complicated.

July 3, 2019 at 11:27 am #4135485

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

The missing fields for this page are custom fields and you need to follow the steps described in this link to translate them: https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

This teme is adding custom Visual composer elements (shortcodes) and custom fields that doesn't have a proper language configuration file for WPML to map them. That's why I recommended you in my previous message to contact the authors and ask them to visit the link, so they can create a complete language configuration file for the theme.

Regards,
Carlos