Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 3 voices.

Last updated by Radu 8 months, 3 weeks ago.

Assigned support staff: Radu.

Author Posts
October 20, 2020 at 3:01 pm #7267401

jonathanF-3

Some settings page are not loading, we are getting blank pages when we try to access :
- Translation management
- Translation
- Settings

We've downgraded PHP to 7.1, still not working.

October 20, 2020 at 3:03 pm #7267477

jonathanF-3

Here's a screencast of the problem : hidden link

October 20, 2020 at 7:14 pm #7269149

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there.

That's pretty weird and it looks like a compatibility issue or server-related issue.

Please try this:

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

❌ Very important: please make a backup of your site (files & database) before following any of the upcoming steps ❌

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

2. Please take a look at the WPML minimum requirements here and we make sure they are fully met:
https://wpml.org/home/minimum-requirements/

3. Make sure that the theme you are using and all the plugins are using the latest versions. If not, please update them to the last version, only after you create a full website backup.

4. If the issue still persists, we will need to check for a possible theme or plugin conflict.

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Please let me know how that goes and if following any of these steps solved your issue or brought any change.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

October 26, 2020 at 2:03 pm #7308573

jonathanF-3

Here's what we did :
1. Increased memory : didn't solve the issue.
2. Looks like we meet WPML minimum requirements.
3. We updated WPML to the latest version (update wasn't showing in dashboard, but we did update manually) : didn't solve the issue
4. We deactivated ALL plugins except WPML ones & reverted to 2020 theme and the issue was still there.

October 26, 2020 at 2:11 pm #7308637

jonathanF-3

We are having the same exact problem as described here in this thread : https://wpml.org/forums/topic/wplm-blank-settings-page/page/2/

If we deactivate the translation management plugin, we are able to access the setting page. Are you able to see if it's the same problem & run the sql command if it's the same problem?

October 26, 2020 at 2:16 pm #7308719

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there.

Welcome back and thank you for the feedback.

1. Can you please create a full website backup and confirm that you have a full website backup?
2. I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

October 27, 2020 at 10:39 pm #7321115

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the credentials.

I can confirm that I was able to log in successfully.

I am spending more time on this and I will get back to you as soon as I have more feedback.

I will leave the ticket assigned to myself for the moment.

Kind regards,
Mihai

October 30, 2020 at 6:48 pm #7346551

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there.

Nothing that I tried didn't work. I was now going to reinstall the plugins from scratch to see if anything is changing but it seems that there are some server limitations.

I'm attaching a screenshot below - can you please take care of that so that I can install the WPML plugins from scratch?

Also, if there's any existing caching or CDN, can you please clear/delete it?

I will be waiting for your response.

PS: Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

Screenshot 2020-10-30 at 8.46.36 PM.png
October 30, 2020 at 6:56 pm #7346579

jonathanF-3

Hi Mihai,

we've added the following to the htaccess :
php_value upload_max_filesize 64M
php_value post_max_size 128M
php_value memory_limit 256M
php_value max_execution_time 300
php_value max_input_time 300

October 30, 2020 at 6:58 pm #7346581

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

I'm still receiving the same error when I try to update our plugin. I think you need to update the php.ini file records as the error message shows and not update the htaccess file.

November 2, 2020 at 2:15 pm #7358723

jonathanF-3

Our site is down. We need quick help. PHP ini file should be ok now

November 2, 2020 at 2:18 pm #7358859

jonathanF-3

We've re-uploaded the WPML files. Site is now working. We would have appreciated to be notified that the site was down 3 days ago. We lost 3 days of traffic.

November 2, 2020 at 4:13 pm #7359817

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there.

I am very sorry to hear about the fact that your website was down.

On 30 October (Friday) the website was working fine for me, I even replied back to you while I was in my shift still, all I could not do is import one of our plugins - then I did not work in the weekend and I came back today.

Can you please give me your written consent to duplicate this website on a local environment so that I can see if there's anything that I can find out more about this?

I will also escalate this ticket to our Tier 2 Support in case I will be able to replicate the same issue on my local so that they can dig even deeper.

However, I need your approval for creating a duplicate of the website.

Please let me know if that's ok with you.

Kind regards,
Mihai

November 2, 2020 at 8:31 pm #7361917

jonathanF-3

Hi, yes you can duplicate the site, just make sure to trash it after we are done. All WPML plugins were gone, that's why the site wasn't working. Please note that since we re-installed the plugins the "case study" (main menu item) page (in french) isn't working anymore. It's working in english, but not french. That's the only page not working (weird).

November 3, 2020 at 12:55 am #7362737

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Thank you for the confirmation.

I will get back to you as soon as I have more information on this.

The topic ‘[Closed] WPML Settings page are not loading’ is closed to new replies.