This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 5.89 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Jamal 7 months, 3 weeks ago.

Assigned support staff: Jamal.

Author Posts
February 20, 2019 at 10:57 am

matthijsI

Hi!

Since we are using WPML the websites speed increased drastically.
We have the exact same website without WPML which loads < 1s.
With WPML it loads > 4s. I included a pastebin for further debug details.
Both website run on a dedicated server.

https://pastebin.com/se1kBgk7

Disabled:
- Auto ID adjust state (WPML > Languages)
- Track where strings appear (WPML > String translation)
- Auto register strings(WPML > String translation)

- Updated to latest versions

February 20, 2019 at 4:36 pm #3222961

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

I logged into your backend and checked the mentioned settings, all seems good.
Please go to WPML->Support->Troubleshooting and perform the action "Recreate ST DB cache tables". Make sure to have a database backup before proceeding

Does this resolve the performance issue ?

Best regards,
Jamal
WPML Support

February 20, 2019 at 9:10 pm #3223767

matthijsI

Hi,

Thank you for your help.
I performed "Recreate ST DB cache tables" but it didn't resolve the issue.

Kind regards

February 21, 2019 at 12:52 pm #3227487

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your feedback.
Please increase the WP Memory Limit to at least 128M, we recommend having 256M.

If this does not solve the issue, would it be possible to retry the tests with the following scenarios:
- Switch to default theme(Twenty Seventeen).
- Deactivate all plugins except WPML Multilingual CMS.
- Reactivate all plugins except WPML add-ons (String Translation, Translation Management and)
- Reactivate String Translation.
- Reactivate Translation Management.
This would lead us to a possible conflict with the theme, another plugin or our add-ons (String Translation and Translation Management).

I hope this is not too much to ask, but this would help us a lot narrow this issue very quickly.

Best regards,
Jamal
WPML Support

February 25, 2019 at 11:18 pm #3242325

matthijsI

We see improvements after Divi theme update and other WPML updates. Will let you know if the issue is revolved! Thanks so far

February 26, 2019 at 8:08 am #3243428

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your feedback. I remain at your disposal.

Best regards,
Jamal
WPML Support

The topic ‘[Closed] WPML slowing down drastically’ is closed to new replies.