Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 1 reply, has 2 voices.

Last updated by Mohammed 6 years, 3 months ago.

Assigned support staff: Mohammed.

Author Posts
August 18, 2015 at 9:02 pm #681857

dragosS

I am trying to: With WPML activated website loads slowly

URL of (my) website where problem appears: hidden link

I expected to see: On the P3 plugin i get the following:

WordPress Plugin Profile Report
===========================================
Report date: August 18, 2015
Theme name: Alpaccess 2014
Pages browsed: 5
Avg. load time: 2.1854 sec
Number of plugins: 32
Plugin impact: 83.49% of load time
Avg. plugin time: 1.8247 sec
Avg. core time: 0.2223 sec
Avg. theme time: 0.0055 sec
Avg. mem usage: 151.40 MB
Avg. ticks: 165,926
Avg. db queries : 128.40
Margin of error : 0.1329 sec

Plugin list:
===========================================
P3 (Plugin Performance Profiler) - 0.0069 sec - 0.38%
Advanced Custom Fields Contact Form 7 Field - 0.0016 sec - 0.09%
Advanced Custom Fields - 0.0318 sec - 1.74%
BulletProof Security - 0.0313 sec - 1.72%
Cleanerpress - 0.0230 sec - 1.26%
CloudFlare - 0.0028 sec - 0.15%
Contact Form 7 Skins - 0.0067 sec - 0.36%
Contact Form 7 - 0.0313 sec - 1.71%
Cookie Law Info - 0.0107 sec - 0.59%
EWWW Image Optimizer - 0.1475 sec - 8.08%
Far Future Expiry Header - 0.0005 sec - 0.03%
Grid Accordion - 0.0170 sec - 0.93%
Inline Google Spreadsheet Viewer - 0.0014 sec - 0.08%
Jetpack by WordPress.com - 0.2015 sec - 11.04%
MailPoet - Contact Form 7 Integration - 0.0005 sec - 0.03%
Post Duplicator - 0.0022 sec - 0.12%
Posts 2 Posts - 0.0424 sec - 2.32%
Really Simple CAPTCHA - 0.0020 sec - 0.11%
Revision Control - 0.0034 sec - 0.19%
Sitepress Multilingual Cms - 0.5084 sec - 27.86%
Visualizer - 0.0043 sec - 0.24%
Wordfence Security - 0.0383 sec - 2.10%
Wordpress Seo - 0.0742 sec - 4.07%
Wp Minify Fix - 0.0069 sec - 0.38%
WP-Optimize - 0.0136 sec - 0.74%
WP Retina 2x - 0.0316 sec - 1.73%
Wpml Cms Nav - 0.0058 sec - 0.32%
Wpml Media - 0.0069 sec - 0.38%
Wpml Sticky Links - 0.0103 sec - 0.57%
Wpml String Translation - 0.4776 sec - 26.17%
Wpml Translation Management - 0.0438 sec - 2.40%
Wysija Newsletters - 0.0385 sec - 2.11%

WPML in total takes 60% of the total loading time

I have switched off string tracking, automatic registering of strings and Adjust IDs for multilingual functionality

Can you please tell me what to do to decrease the loading time,

Thank you

August 19, 2015 at 2:43 pm #682470

Mohammed

Hello,

Thank you for contacting WPML support forum.

Please try the following in the minimal environment.
- Minimal environment: Deactivate all Non-WPML plugins and activate a default WordPress theme e.g. “Twenty Fifteen”.

Please review this article: http://wpml.org/2012/01/can-your-site-run-faster/, especially the section under “Using WPML Better” and confirm that the following settings are OFF or disabled.

- Auto ID adjust state
- Track where strings appear
- Auto register strings

Also please review this : https://wpml.org/2015/04/wpml-3-2-performance-improvements/ , it's talking about the performance improvements at the 3.2 version.

// NOTE : Please make a complete backup of your website, before updating. The update should go without problems, but in case something goes wrong it is good to have a backup.

Regards.

The topic ‘[Closed] WPML slows down website’ is closed to new replies.