This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: WPML disappeared from WP main menu. Sorry, you are not allowed to access this page.

Solution: Use the code in the following post to fix the issue: https://wpml.org/forums/topic/wpml-sorry-you-are-not-allowed-to-access-this-page/#post-1009975

This topic contains 4 replies, has 3 voices.

Last updated by Vincenzo 1 year, 8 months ago.

Assigned support staff: Vincenzo.

Author Posts
August 19, 2016 at 2:23 am #1009790

Jean Dupond

WPML disapeared from main WP menu.
When I access from Plugins > WPML > Configure, I get this error.

I am trying to:
Access WPML

URL of (my) website where problem appears:
hidden link

I expected to see:
WPML menu

Instead, I got:
Sorry, you are not allowed to access this page.

Steps to duplicate the issue:
Login to backoffice, see that there is no WPML menu, then go to Plugins > WPML > Configure

I changed the keys of wp-config.php already

Thanks in advance

August 19, 2016 at 7:35 am #1009975

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello, thank you for contacting WPML Support!
I will take care of your ticket.

To fix this, I suggest you run the following snippet:

function wpmlsupp_1706_reset_wpml_capabilities() {
    if ( function_exists( 'icl_enable_capabilities' ) ) {
        icl_enable_capabilities();
    }
}
add_action( 'shutdown', 'wpmlsupp_1706_reset_wpml_capabilities' );

Just add the above code in your theme's functions.php file (between the <?php and ?> tags) and visit once the front-page.
Then you can remove this snippet.

Please let me know if this fixes the issue.

Thank you!

August 19, 2016 at 8:08 am #1010020

Jean Dupond

It fixed the issue, thank you !

March 20, 2018 at 2:39 pm #1551102

roosS

I have the same issue, I can't even login anymore to myadmin with the same error message as described above. It is the WPML CMS management plugin causing troubles. I tried the above solution but for me it did not work (website holidaysdolomites.com). After entering the code in the functions php file I received an error message saying: "Scrape nonce check failed. Please try again."

March 20, 2018 at 2:44 pm #1551110

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello @rooss,

this ticket is closed.

May I ask you to open a new ticket?

You can do it from here: https://wpml.org/forums/forum/english-support/
You can assign it to me if you wish.

Thank you