This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Bruno 4 weeks, 1 day ago.

Assigned support staff: Bruno.

Author Posts
May 25, 2020 at 1:00 pm #6210371

Денис Стефанюк

Hello!
While trying to install the plugin, I received the message:

"WPML String Translation is attempting to write .mo files with translations to folder:
/var/www/chillandgrill/chillandgrill.es/wp-content/languages
This folder appears to be not writable. This is blocking translation for strings from appearing on the site.
To resolve this, please contact your hosting company and request that they make that folder writable.
For more details, see WPML's documentation on troubleshooting .mo files generation..".

I have completed all the suggestions for solving this problem:

- checked permissions of the languages folder (777)
- wrote to the support service of the hosting provider
- tried to install an older version of the plugin

but all this did not help.

Please help solve this problem.

May 26, 2020 at 9:13 pm #6223551

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you for contacting us. Please as a test, could you disable all non-WPML plugins, switch to the default theme and see if the problem persists?

If the problem is fixed, please, enable the plugins one by one to see if there is any compatibility problem between these plugins.

If the problem persists, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

May 29, 2020 at 12:10 am #6244293

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. My IP changes very often. That way, even sending it, in a short time my IP will be changed again and I will lose access. Would you be able to change this FTP setting while I check your site and then activate it again?

Also, please, could you configure WPML? At the moment I see that WPML has not yet been configured initially.

Thank you.

May 29, 2020 at 12:25 am #6244327

Денис Стефанюк

Hello! I pre-configure the plugin and disabled FTP restrictions. Please write as soon as I can turn them back on. How soon you can give me any news about this issue? It really imporatnt to solve this problem as soon as possoble. Thank you

May 29, 2020 at 12:27 am #6244329

Денис Стефанюк

One more thing: i can't find how to change language of plugin to English. My web site now is on Spanish, but i prefer to have english interface. Thnx

June 2, 2020 at 12:16 am #6268817

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

When I try to access your FTP, it looks like the password is incorrect:

Status:	Resolving address of *******.net
Status:	Connecting to *******:21...
Status:	Connection established, waiting for welcome message...
Status:	Insecure server, it does not support FTP over TLS.
Command:	USER *******
Response:	331 Password required for chillandgrill_temp
Command:	PASS ************
Response:	530 Login incorrect.

If necessary you can edit your private message (highlighted) above.

>>> One more thing: i can't find how to change language of plugin to English. My web site now is on Spanish, but i prefer to have english interface.

You can change the default language at WPML > Languages > Change default language or, if you want to change the WordPress interface, click on the Users > Your Profile and change the "Language".

Thank you.

June 2, 2020 at 11:37 pm #6277775

Денис Стефанюк

Hi! I can't understand how its has happend, but temporary account that i have made has been deleted. Try now please with the same login and password. Thnx

June 3, 2020 at 2:15 am #6278155

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. I have fixed the problem you are reporting. This happened for some reason because of the cache. It appears that the cache for this error message was not removed correctly.

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

June 3, 2020 at 3:16 pm #6285203

Денис Стефанюк

Hi! Thank you so much! But could you explain to me in more detail how you has fix this problem? Because i will use WPML in other sites at the same hosting and i don't want to disturb you again with the same problem.

June 3, 2020 at 4:54 pm #6286023

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

At the time WPML was installed, the directories were probably not with the correct permissions. After changing the permissions of the directories, this should work correctly.

The problem happened because the message was cached within the database. That is, even setting the directory permissions, the message was still displayed, but it was a false positive. What I did was just update the database to remove the cache of invalid notices.

That is, the real problem was just the cached message. No configuration or changes were made, just removing the invalid cache.

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.