Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Frank 1 year, 8 months ago.

Assigned support staff: Noman.

Author Posts
March 5, 2018 at 1:19 pm

Frank

I am trying to:
Active the plugin "WPML String Translation". After activation, I cannot edit my posts anymore, as it is causing a HTTP 500 error. I tested this situation on a blank site with the default theme and no plugins other than WPML activated.

Error messages in the debug.log are like this one:
[05-Mar-2018 11:13:42 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 32 bytes) in /is/htdocs/wp11200660_C7Z12DTV9L/www/initiative-online-print.de/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/persist/class-wpml-st-page-translations-persist.php on line 101

The server the website is on has 128MB memory, that is plenty.

Link to a page where the issue can be seen:
hidden link

I expected to see:
A working WP backend that allows me to use all functions like post editing and does not cause a HTTP 500 error.

Instead, I got:
a "HTTP 500" error

March 6, 2018 at 10:20 am #1537430

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Frank,

Thank you for contacting WPML Support. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/** WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Thank you

March 6, 2018 at 1:19 pm #1537657

Frank

Hey Norman,
Thank you for the response. I have added the code to wp-config.php (adjusted to 128M) but the error persists.

I cannot open the post editor when "WPML String Translation" is enabled. When I disable the plugin, the post editor is working fine.

This is the latest message in the error.log:
[06-Mar-2018 13:18:19 UTC] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 65536 bytes) in /is/htdocs/wp11200660_C7Z12DTV9L/www/initiative-online-print.de/wp-includes/wp-db.php on line 2510

March 6, 2018 at 3:52 pm #1537881

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Sixteen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

If still issue persist, please backup your database and website.

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

March 7, 2018 at 11:23 am #1538932

Frank

Hey Noman,
please do not deactivate themes or plugins on the site I gave you, it is a live website. I will provide a development copy of the site on the same server.

March 7, 2018 at 12:28 pm #1539014

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Frank,

Okay waiting for development site to debug this issue. I have enabled private message box.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

March 13, 2018 at 8:39 am
March 13, 2018 at 9:39 am #1544500

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello Frank,

I am unable to reproduce this issue in your test site. I have followed following steps:
- Activate wpml string translation plugin
- Update post as in attached screenshot.

Can you please let me know if all is okay now or do I need to follow some other steps to reproduce the issue you were having?

Thank you

March 23, 2018 at 7:09 am #1554598

Frank

Hey Noman,
It seems to be working now, however we didn't change anything in the configurations. That's weird, but let's close this ticket for now.

Thanks!