Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Bigul 7 months ago.

Assigned support staff: Bigul.

Author Posts
January 15, 2020 at 5:57 pm #5300417

Nikita Nanos

I am trying to: Have a functioning FR website

Link to a page where the issue can be seen: I deactivated the String translation plugin as it made the FR website crash. Whenever I activate it, our FR website shows a critical error.

I expected to see:

Instead, I got: This is the second time I have had to open a ticket for this problem. Previously, they had found a bug with a time zone string that caused it to crash and I had to remove it for it to work again. This time, this does not seem to fix the problem.

January 16, 2020 at 1:00 pm #5305539

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve the issue.

Please share with me the WordPress debug.log (not WPML debug information) for tracking the issue.

Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

February 10, 2020 at 3:40 pm #5462991

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

My colleague Mihai has shared your Debug log details with me. Debug log is showing a fatal error but most probably it will not be related to this issue.

Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

Also, please allows me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

February 11, 2020 at 5:07 am #5466195

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information and permission. But I am not able to login to the WordPress dashboard because of the wrong password. Please check. FTP credentials are working fine for me.

ERROR: The password you entered for the email address ******.com is incorrect. Lost your password?

--
Thanks!

Bigul

February 11, 2020 at 4:28 pm #5471281

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I can log in to the site now. But not able to create a Duplicator copy of the site because of the *Scan Error*. Please check the attached image. The result is the same with Duplicator free and Pro version.

Have you had this error before? Because the site has old Duplicator backups. I will try it again after some time.

--
Thanks!

Bigul

February 12, 2020 at 7:40 am #5474663

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

After serval tries, I was able to make a Duplicator copy of your site now using Duplicator Pro plugin. I will debug the issue further and get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

February 13, 2020 at 5:50 am #5483261

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

This bug is happening because of a conflict with the time zone settings. The French section of the site shows the following error when String Transalation is active. It works in my local copy when I choose UTC time for the Timezone field of Settings>>General. Please try it after a site backup and let me know your feedback. Check the attached image for more details.

PHP Fatal error:  Uncaught Exception: DateTimeZone::__construct(): Unknown or bad timezone (Amérique/Toronto) in C:\xampp\htdocs\nanos\wp-includes\functions.php:137
Stack trace:
#0 C:\xampp\htdocs\nanos\wp-includes\functions.php(137): DateTimeZone->__construct('Am\xC3\xA9rique/Toron...')
#1 C:\xampp\htdocs\nanos\wp-includes\functions.php(35): wp_timezone()
#2 C:\xampp\htdocs\nanos\wp-includes\class-wp-query.php(4256): mysql2date('d.m.y', '2017-06-08 22:2...', false)
#3 C:\xampp\htdocs\nanos\wp-includes\class-wp-query.php(4205): WP_Query->generate_postdata(Object(WP_Post))
#4 C:\xampp\htdocs\nanos\wp-includes\class-wp-query.php(4336): WP_Query->setup_postdata(Object(WP_Post))
#5 C:\xampp\htdocs\nanos\wp-includes\query.php(130): WP_Query->reset_postdata()
#6 C:\xampp\htdocs\nanos\wp-includes\query.php(115): wp_reset_postdata()
#7 C:\xampp\htdocs\nanos\wp-content\plugins\sitepress-multilingual-cms\sitepress.class.php(2993): wp_reset_query()
#8 C:\xampp\htdocs\nanos\wp-content\plugins\sitepress-multilingual-cms\classes\class-wpml in C:\xampp\htdocs\nanos\wp-includes\functions.php on line 137
[13-Feb-2020 05:32:04 UTC] PHP Warning:  timezone_open(): Unknown or bad timezone (Amérique/Toronto) in C:\xampp\htdocs\nanos\wp-includes\functions.php on line 5442

The bug is existing on my local copy in a minimal setup when the Timezone value is *Toronto*. But not able to reproduce the issue in fresh or my other testing installations. Therefore I will consult with our second-tier team for the expert opinion and get back to you soon. Please wait.

--
Thanks!

Bigul

February 18, 2020 at 1:39 pm #5515623

Nikita Nanos

Hi Bigul,

Any luck checking with your second-tier team?

February 19, 2020 at 4:22 am #5520261

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

We have a workaround for this issue. Somehow String Translator is automatically translating the "timezone_string" value and it is causing this issue. We are getting the expected result after the following steps. Please try it after a site backup and let me know your feedback.

1) Activate WPML String Translation
2) Visit WPML>>Settings>>Custom XML configuration
3) Add the following configuration code in *Custom XML configuration* field

<wpml-config>
  <admin-texts>
  	<key name="timezone_string"></key>
  </admin-texts>
</wpml-config>

4) Save the changes
5) Visit WPML>>String Translation
6) Translate the timezone string with the same value

Please check the attached images and the following documentation link for more details.

https://wpml.org/documentation/support/language-configuration-files/#admin-texts

--
Thanks!

Bigul

February 19, 2020 at 2:08 pm #5524659

Nikita Nanos

Hi Bigul,

I followed the instructions and it seemed to work for a couple minutes, but then I tried to translate our "reports" page and it is giving me this message (see image attached) that there is a critical error.

February 19, 2020 at 3:54 pm #5525663

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

This issue is not related to WPML String Translation and it is happening because the Max execution time is not set for your site. Please check the attached image. So we will get the following error.

PHP Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\nanos\wp-content\plugins\wpml-translation-management\classes\xliff\class-wpml-tm-validate-html.php on line 81

It works on my local copy when I increased the maximum execution time to 300 in PHP ini settings. Please check the following article for more details. May you have to contact your hosting provider to update this configuration.

hidden link

Please try after upgrading the maximum execution time to 300 and let me know your feedback. You can check the status of in *PHP Info* section of the WPML>>Support page.

--
Thanks!

Bigul