Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: WPML string translation make the woocommerce cart empty after booking

Solution: Go to WooCommerce -> WooCommerce Multilingual -> Settings -> Cart -> Switching languages when there are items in the cart and choose "Prompt for a confirmation and reset the cart" to fix the issue.

This option will reset the cart once the client changes the languages.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by mohamedt-3 2 years, 10 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
July 23, 2018 at 8:28 pm

mohamedt-3

I am trying to:
Book a tour from the booking form and after booking i get empty cart page,

Link to a page where the issue can be seen:
The booking form in every Product page .. Example ( hidden link )

I expected to see:
after booking in every single Products page i go to the Checkout Page

Instead, I got: empty cart page hidden link

NOT :
wpml string translation make the woocommerce empty after booking and when i Deactivate the plugin it work perfectly,
Best Regards,
Kazem.

July 25, 2018 at 8:26 am #2578563

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

We recently released new versions of WPML plugins with fixes and improvements so could you please update the plugin to the latest version and let me know if this helps?

NOTE:

+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

Keeping string translation active, If you disable all non-related WPML plugins, switch to one of the default themes, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Look forward to your reply.

Thanks

July 25, 2018 at 12:43 pm #2579483

mohamedt-3

hwllo Shekhar,
i update the plugins to the latest version and i switch to one of the default themes but still have the problem !!
Best Regard,
Kazem

July 26, 2018 at 1:12 pm #2584348

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

To further debug this issue, could you please provide me a backup of your wp-content (without uploads) as well as database backup so I can replicate your site on my localhost and perform further debugging.

You can zip these files and upload to google drive later to share it with me.

Look forward to your reply.

Thanks

July 26, 2018 at 4:35 pm
July 27, 2018 at 11:35 am #2588038

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I am working on this issue and will respond to you soon.

Thanks

July 30, 2018 at 2:58 pm #2594639

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Please go to WooCommerce -> WooCommerce Multilingual -> Settings -> Cart ->
Switching languages when there are items in the cart and choose "Prompt for a confirmation and reset the cart" to fix the issue.

This option will reset the cart once the client changes the languages.

Let me know if this helps.

Thanks

August 2, 2018 at 2:22 pm #2605682

mohamedt-3

thank you Shekhar the problem fixed .