This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.21 hours from now. Thank you for your understanding.

This topic contains 1 reply, has 2 voices.

Last updated by Bigul 1 year, 5 months ago.

Assigned support staff: Bigul.

Author Posts
May 9, 2018 at 8:51 am #2047256

Martin

Hi

I received following error report from the cloudeflare support:
Not only the backend but the frontend was also giving 500 error. I checked further and found that it was the plugin 'wpml-string-translation' which was causing issue and hence I had to disable it by renaming it to wpml-string-translation_rename.
The site and backend are loading all fine now. I would suggest you contact the developer of the plugin who can assist you further in getting this issue resolved. Below is the error which you may send to developer:
[Mon May 07 20:56:12 2018] [warn] [client 2405:201:2000:fff5:1dae:3143:e8fa:812c] mod_fcgid: stderr: #2 /mnt/data/vhosts/casite-599438.cloudaccess.net/httpdocs/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/class-wpml-st-db-translation-retrieve.php(139): WPML_ST_DB_Translation_Retrieve->build_translation(Array, '[cptui_ in /mnt/data/vhosts/casite-599438.cloudaccess.net/httpdocs/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/class-wpml-st-page-translation.php on line 103

Any idea why this is happening and how to fix it?
I disabled the plugin for the moment and now all is working fine.

Regards,
Chris

May 10, 2018 at 8:49 am #2067817

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Chris,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

We had similar issues in the past. But in this case error log(the one you have shared) is missing some information. So please do the following steps.

Please upgrade to WPML 3.9.4 after a site back up and activate String Translation. Then please add the following code in wp-config.php file of your site to enable WordPress to debug mode. In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are still getting the errors or not.

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );
 
// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

Also please increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Check the following links for more details

https://wpml.org/home/minimum-requirements/

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

--
Thanks!

Bigul

The topic ‘[Closed] WPML String Translation | problem with Cloudeflare’ is closed to new replies.