This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 29 replies, has 4 voices.

Last updated by Andrey 4 months, 3 weeks ago.

Assigned support staff: Andrey.

Author Posts
April 23, 2019 at 2:21 pm #3664651

leonardoA-12

Hi, we use wordpress 4.9.8 on bitnami aws ec2 server. The error message say "There is a problem with the String Translation table in your site. This problem is not causing a problem running the site right now, but can become a critical issue in the future. WPML support team knows how to fix it. Please add a message in the relevant support thread and we'll fix it for you." appear only on backend, how can fix?

thanks, regards.

April 23, 2019 at 6:40 pm #3666953

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Upgrade to the latest version of WPML(4.2.6)

2) Go to WPML>>Support page

3) Click on Troubleshooting link (blue link in the middle of the page)

4) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

--
Thanks!

Bigul

April 24, 2019 at 2:00 pm #3673687

leonardoA-12

Hi Bigul, I followed all the steps and the error message continues to appear.

When i uploaded the latest version of WPML, three folders / files failed, I attach a screenshot.

Wait ur solution, thanks.

April 24, 2019 at 5:40 pm #3675609

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please try to upgrade the plugin automatically from the Plugins page.

Please check the following documentation for more details.

https://wpml.org/faq/install-wpml/#automated-updates

Please share with me the WordPress debug.log (not WPML debug information) for tracking the issue. Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

April 24, 2019 at 6:06 pm #3675777

leonardoA-12

Hi Bigul, sorry but i dont have permissions to update from PLugins page (screenshot attached).

I think is for AWS security, but i dont know what can do. U can tell me please.

Thanks. Regards.

April 25, 2019 at 8:13 am #3679989

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

April 25, 2019 at 4:11 pm #3684451

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. But it shows the following error while login. Please check.

ERROR: The username or password you entered is incorrect. Lost your password?

--
Thanks!

Bigul

April 25, 2019 at 7:06 pm #3685311

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. The WPML core plugin is upgraded to the latest version and WPML String Translation & Translation Management plugins required an upgrade.

With current admin permissions I am not able to access Plugins>>Add New page or Dashboard>>Updates page. So it is not possible to register WPML for automatic upgrading. But you can try manual upgrading after a backup. Please check the following documentation for more details.

https://wpml.org/faq/install-wpml/#updating-manually

I have a request for further cross-checking. Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

April 25, 2019 at 8:38 pm #3685809
leonardoA-12

Hi Bigul, thanks for ur answer.

I dont have access to the options of Plugins and Updates, i dont understand why. I think is about of AWS Bitnami WordPress config not?

Recently we updated your plugins manually, please check again.

Duplicator is active now, check too. U knok when click on Duplicator's activate button, the WPML config assistance is appear, is so freak. When activated Autoptimize plugin, the same thing happened. Screenshot Attached.

I had to disable the Autoptimize plugin because it broke the front design. Maybe is incompatible with WPML.

In addition to this problem, I could not register the plugin either, I suppose it's because of server security issues (AWS EC2) but I need to know what the alternative is to do it.

Wait ur help, thanks! Regards.

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/split-compatibility-issues-with-autoptimize-plugin/

April 26, 2019 at 9:01 am #3688997

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates and permission. But I am not able to make a Duplicator copy of your site because of their lack of write privileges to Duplicator plugin folders. Please check the attached image for more details.

Please check all the Administrative users having the same issues. This may be because of security settings.

Please note, I have opened a new ticket for the Autoptimize plugin issue. Because as per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket. I will get back to you soon on the new ticket. Please wait. Thank you for your understanding.

--
Thanks!

Bigul

April 26, 2019 at 1:14 pm #3690901

leonardoA-12

Hello Bigul, sorry for the inconvenience.

I created and changed permissions of Duplicator for you. I'm new with AWS EC2 & Bitnami, so i don't know which is recommended for security and solve this problems.

Please check if now is Ok, and u can create a package with plugin. I need first resolver the problema with String translations for begin to translate widgets and content of the site.

I will check the other issue (Autoptimize) in the other ticket.

Thanks, regards!

April 26, 2019 at 5:45 pm #3692695

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I can make a duplicator copy of your site now. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

April 26, 2019 at 8:02 pm #3693187

leonardoA-12

Ok Bigul, I will be here waiting for the solution.

April 28, 2019 at 4:41 am #3697225

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind information, the issue is existing after the initial debugging steps. Somehow few of the fields of *_icl_strings* and *_icl_string_translations* tables were missing. But the problem remains after adding those fields.

Therefore I will be forwarding the details to our second tier team for further debugging. We will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

May 1, 2019 at 5:52 pm #3719265

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

This is Andrey here. Bigul has handed your ticket to me. I'll help you to fix this issue.

Could you please check the FTP access it doesn't work for me? I'd like to check the WPML's tables in your current website.

The next reply is set as a private.