This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Yvette 2 months, 2 weeks ago.

Assigned support staff: Yvette.

Author Posts
August 1, 2019 at 1:24 pm

petrS-7

I am trying to: solve the problem with "It looks like languages per directories will not function"

Link to a page where the issue can be seen: hidden link

I expected to see: no red warning messages, but I tried to solve this according this post https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/ but in .htaccess is everything correct.

Instead, I got:

August 1, 2019 at 6:18 pm #4324627

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

hello

The problem might be related to this error message: "cURL error 28: connect() timed out!"

Can you please ask your server/hosting support for assistance to install the latest CURL extension on your site.
Here is more info on this:
hidden link

Please try this and let me know if it resolves the issue.

August 5, 2019 at 1:03 pm #4340705

petrS-7

Hello,

which curl version is mandatory to have? We have older linux server and we have curl 7.19.7 and cant upgrade it without the upgrade of server.

August 5, 2019 at 3:07 pm #4341549

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I am not sure, to be honest, but this problem can happen with older versions of curl. I¨ll try installing your duplicator package on a local server to eliminate the possibility that this is indeed the issue.

I´ll get back to you as soon as I can.

August 5, 2019 at 4:38 pm #4342033

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

It seems like the version required is at least: I think 7.34.0

See https://wpml.org/errata/wpml-could-not-load-configuration-files-which-your-site-needs/

Perhaps to rule out the possibility that this is the heart of the problem, you can send me a copy of your site for me to install on my local server. If my local server has the same issue - then we know it is not related to the cURL library since my PHP has the required level.

More here:
https://wpml.org/faq/provide-supporters-copy-site/

I´m opening the private area for a download link to the Duplicator pcackage. Please use a file sharing service like WeTransfer and do not attempt to upload the files to the forum.

THanks

The topic ‘[Closed] WPML tells me "It looks like languages per directories will not function"’ is closed to new replies.