This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by Bruno Kos 5 months ago.

Assigned support staff: Bruno Kos.

Author Posts
February 6, 2019 at 12:18 pm #3165421

mehdiI-3

The whole website works, I use a compatible theme but when trying to visit articles, it says "too many redirects".
What I tried to do is uninstall all other plugins, refresh permalinks and even change to defaut theme but the issue is still there...

Link to a page where the issue can be seen:
hidden link

I expected to see:
A page that works.

Instead, I got:
A message, see photo.

February 6, 2019 at 12:26 pm #3165465

mehdiI-3

Let me know when you'll check the issue: I have currently deactivated the plugin because we have 500-800 visits per day and can't take the risk to lose these people.

Please let me know how to proceed.

February 7, 2019 at 8:27 am #3168948

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

From what I gather, WPML is still not active, correct (because I see both pages)?

Could you make sure your server conforms to our minimum requirements?
https://wpml.org/home/minimum-requirements/

Based on provided debug information, I can see the following - WP Memory Limit: 40M.

Specifically, could you set WP Memory limit to at least 256MB and then let me know if this fixed your issue?
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

If unsure on how to set this, you can consult your host/server admin to do this. After you increase this value, you can confirm it by checking on WPML -> Support by finding the “Memory limit” value.

Furthermore, I can see that you've already changed permalinks and resaved and that it didn't help. Can you also try the following options:

1) Change the default language
2) Update WPML -> Languages -> Language URL format (just resave)

Also, do you know when has this started happening? One other thing - did you make change changes in htaccess file or used some redirection plugin before?

Also, we have WPML 4.2. shipped yesterday - if you are not seeing an update, can you download the plugin from here directly - https://wpml.org/account/downloads/ - delete your existing WPML and upload this one (deleting the plugin will not remove translations or settings - but make a full backup first just in case).

I am sorry if I put all this information at once, but I'd like to try every possible scenario before checking this further.

Regards,
Bruno Kos

February 7, 2019 at 10:05 am #3169457

mehdiI-3

Hi,
Thank you for your answer. I reactivated the plugin.

I increased WP Memory Limit: 256MB.

Did both of these:
1) Change the default language
2) Update WPML -> Languages -> Language URL format (just resave)

To reply to your question: it never worked. Actually, I just installed WPML yesterday.

Please note that WPML in itself seems to work. WPML is working, otherwise, it would not translate "Page not found" message in different languages.

Thanks in advance for your prompt reply.

February 7, 2019 at 10:41 am #3169628

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Did you also try deleting all WPML and addons and tried updating to the newest versions? I suggest we start from there.

So you haven't done any translation yet or made and WPML settings, correct?

Also, did you check if there's anything within htaccess file or used some redirection plugin before that could have caused this?

Regards,
Bruno Kos

February 7, 2019 at 10:56 am #3169750

mehdiI-3

Hello,
I'm running on latest version of WordPress and have installed WPML 4.2 – update from yesterday. I have no addons.

this is what I also tried to do:
reset completely the plugin and start again from scratch. Also didn't worked.

"So you haven't done any translation yet or made and WPML settings, correct?" correct. I just want it to already work in German before starting to translate.

Yes I checked, no redirection plugins are used (I anyway already tried to deactivate all plugins + change to a normal theme, this didn't fix the issue)

Yes, I checked htaccess file, nothing is there concerning a redirect. What could be the problem, is that our blog is really hosted on blog.carhelper.ch and carhelper.ch/blog is a redirect we use, in order to have a page hosted on a different server loading under a main domain (carhelper.ch)

Please let me know what you think.

February 7, 2019 at 11:30 am #3169851

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Given that we've tried everything that was at our disposal - yes, it is possible that this redirection you have there is interfering somehow with WPML and am not sure how. Since only blog is being redirected - is the loop thing happening only in posts within /blog or for regular pages as well?

If that's the case, I will need to ask our 2nd tier for advice, but will need your wp-admin and FTP info.

I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this information. Also, when the work on this ticket is done, please delete these temporary access credentials and/or update passwords.
You can use plugins such as Duplicator ( https://wordpress.org/plugins/duplicator/) or ask your host to perform a site backup.

Regards,
Bruno Kos

February 7, 2019 at 11:50 am #3169900

mehdiI-3

This sounds good.

I'll be doing a backup + saving the database later this week. Our dev will create admin access for you and I'll be coming back with logins on next Monday.

Concerning your first question:
Correct: it's only on articles level. Pages, categories, tag work fine. Just articles.

Please mark my next reply private too :-).

February 7, 2019 at 12:06 pm #3170003

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Marking your next reply as private once again :).

Regards,
Bruno Kos

February 19, 2019 at 3:57 pm #3217860

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I can't seem to login to FTP and I need to escalate this to our 2nd Tier as I am unable to figure out this - can you check FTP creds again? Your next reply is private.

Regards,
Bruno Kos

February 20, 2019 at 9:23 am #3220393

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Ok, this works - however, I can't seem to install this plugin - I am getting various permission errors:
- Duplicator – WordPress Migration Plugin

Can you do this for me and create a package? 2nd tier will need their local copy to debug this.

Regards,
Bruno Kos

February 20, 2019 at 1:13 pm #3221895

mehdiI-3

Hi, the plugin is installed. Please let me know how to proceed next.

February 20, 2019 at 1:25 pm #3221953

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I was able to create a Duplicator package - I need nothing else for now. 2nd tier will investigate this further and I will keep you updated about this!

Regards,
Bruno Kos

February 22, 2019 at 10:03 am #3231721

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

A question:

What could be the problem, is that our blog is really hosted on blog.carhelper.ch and carhelper.ch/blog is a redirect we use, in order to have a page hosted on a different server loading under a main domain (carhelper.ch)

So this a scenario?:
- you created a subdomain "blog" on hidden link
- so that would be hidden link
- you are redirecting this (regular hosting redirect set through cpanel e.g) to hidden link

We are unable to replicate the same issue on our system - we would need more info on how this redirect is being created. Can you send as much as detail on how this works?

Regards,
Bruno Kos

February 25, 2019 at 5:09 pm #3241314

mehdiI-3

1) hidden link - it’s hosted on our nginx server (it’s our dns server, private network)
2) hidden link -> /blog -> nginx reverse proxy to blog.carhelper.ch

We are using cloudflare as load balancer

location ^~ /blog/ {
proxy_pass hidden link;
}

This is our nginx directive in carhelper.ch nginx configuration.