Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Osama Mersal 7 months, 3 weeks ago.

Assigned support staff: Osama Mersal.

Author Posts
April 9, 2021 at 7:44 am #8498973

veeco

Hello

i tried to import Toolset Types from my old website (without WPML) to my new site (Have WPML)

However, after i imported it, my custom fields doesnt show up in admin panel unless i deactivated the WPML, same with views, i need to turn off the WPML for the views to show my templates, otherwise it will ask to create new template

please help

Views On.jpg
Views Off.jpg
CPT On.jpg
CPT Off.jpg
April 11, 2021 at 8:59 am #8509469

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for contacting WPML forums support. I’ll be glad to help you today.

1) I would need to take a closer look at your site. So I would need to request temporary access (WP-Admin and FTP)
– preferably to a test site where the problem has been replicated if possible –
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private, which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme and to change configurations on the site if needed. This is also a reason the backup is critical.

2) It might not be related to the issue, but according to your Debug.info, the WP memory limit needs to be increased. PHP memory is fine, but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb. (Kindly check this page https://wpml.org/home/minimum-requirements/)

Add this to the top of wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Thanks for your cooperation

Regards,
Osama

April 12, 2021 at 7:55 am #8514035

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for providing the access details. Could you please check the password? Because I get "Error: The password you entered for the admin_wpml user was incorrect." message. (Kindly check the attached screenshot)

Thanks,
Osama

1.jpg
April 12, 2021 at 9:20 am #8515371

veeco

Hello, i've updated and double checked

it should works now

April 12, 2021 at 9:44 am #8515695

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

When you click on "Loop Wizard", it will work correctly. (Kindly check the attached screenshot)

Could you please check this at your end?

Thanks,
Osama

1.jpg
April 12, 2021 at 10:13 am #8515905

veeco

Hello

It supposed to load the previous templates that i have created

if i turned off WPML, it will load the correct/old templates that i have created

WPML Off = load the template that i have created
WPML On = no template detected(?)

WPML On = Loop wizard > create template > save > refresh > the saved template isnt loaded/gone

please try it, thank you

April 12, 2021 at 11:21 am #8516413

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for your reply. I've seen the issue. In order to debug the issue, I've installed a local copy of your site, but I didn't face this issue. (Kindly check the attached screenshot)

Could you please if your server has any kind of server cache?

Thanks,
Osama

1.jpg
April 13, 2021 at 3:22 am #8521265

veeco

Hello

i will try to discuss this with my provider

Thank you

April 13, 2021 at 6:34 am #8522099

veeco

Hello

i have discussed and it seems there is caching system that is active and causing this

thank you, and sorry for the trouble

April 13, 2021 at 7:45 am #8522511

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Glad to hear that the cause of the issue is known now. If you need further info, please let me know.

Best regards,
Osama