This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

The translated pages don't keep the same styles and layout of the default language page.

Solution:

1 - Click to edit the page in the default language at WordPress Dashboard > Pages then change to the secondary language where the issue is seen, using the top admin bar language switcher.

2 - Take a detailed look for any page options in the page editing screen and make sure it has the exact same settings of the same page in the default language.

3 - As an alternative it is possible to make the custom fields (which in most cases define the page options) to have its value copied from the default language to the secondary languages and this way keep the page layout and appearance consistency.

Relevant Documentation:

https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

This topic contains 2 replies, has 2 voices.

Last updated by nikolausK-4 2 weeks, 2 days ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
October 1, 2019 at 5:47 pm #4674419

nikolausK-4

I am trying to translate a page and the translated page shows different CSS properties on the navigation bar.
The navigation bar is fixed on top of the page and beneath is a revolution slider. Only on the translated page the CSS of the menu bar does not appear correctly.
Additionally, when scrolling down, the navigation bar loses height and gets thinner which is correct, but when scrolling up it gets bigger and simultaneously pushes down the revolution slider but it should resize without pushing it down.

October 1, 2019 at 8:10 pm #4675267

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. It most likely happens due some inconsistency of your default language and your translated page settings. Please, try the following:

1 - Click to edit your homepage in your default language from your WordPress Dashboard > Pages then change to the secondary language where you see the issue, using the top admin bar language switcher.

2 - Npw, take a detailed look for any header related settings in your page editing screen and make sure it has the exact same settings of this same page in your default language.

Please, let me know if you need any additional assistance and clarifications, have a nice day.

October 2, 2019 at 11:50 am #4679913

nikolausK-4

Thank you for your assistance.
My issue is resolved now.