This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: WPML Translation Basket shows "The site is experiencing technical difficulties. Please check your site admin email inbox for instructions"

Solution:

https://wpml.org/forums/topic/catchable-fatal-error-showing-under-the-translation-basket/#post-3089376

This topic contains 11 replies, has 2 voices.

Last updated by rickardR-2 3 months, 1 week ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
July 5, 2019 at 8:43 am #4149255

rickardR-2

The site is experiencing technical difficulties. Please check your site admin email inbox for instructions

July 5, 2019 at 8:44 am #4149257

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

This must be happening due to some php errors, so could you please perform the below steps and share me the results?

Debugging

1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Look forward to your reply.

Thanks

July 5, 2019 at 8:52 am #4149287

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The provided info is debug information, not debug.log, could you please enabled the wp_debug, wp_debug_log, and wp_debug_display as mentioned in the link and sent us the file from the wp-content folder, the file name should be debug.log, sent us its content.

Thanks

July 5, 2019 at 8:53 am #4149289

rickardR-2

When you go WPML on the left side for the admin, then press translation management, you send a translation to the basket, it starts to blink red in the basket.

July 5, 2019 at 8:56 am #4149295

rickardR-2

You have access to the site, can you not help my retrieve it?

July 5, 2019 at 9:02 am #4149337

rickardR-2

Hi, added it to the file

July 5, 2019 at 9:15 am #4149519

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for the details.

Your current memory limit is set to 40M, while the Minimum requirements are 128MB: https://wpml.org/home/minimum-requirements/

You need to increase the Memory Limit. In order to increase the memory you can add this following code to the top of wp-config.php

define('WP_MEMORY_LIMIT', '128M'); 
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

You can find more about increasing memory allocated to PHP in the WordPress codex, link: https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

Further, the deadlock error happens when two processes is run at the same time, being so Can you confirm that you are still experiencing issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Nineteen)

Look forward to your reply.

Thanks

July 5, 2019 at 9:25 am #4149543

rickardR-2

HI, I got this issue now. See attached. Also added the info as mentioned

July 5, 2019 at 9:30 am #4149615

rickardR-2

After adding the code to wp-config.php is is green, but I got that error messages as shown above in the basket at Translation management.

July 5, 2019 at 9:32 am #4149645

rickardR-2

This message is showing now after the one fix above in the basket(see image)

Fatal error: Uncaught TypeError: Argument 1 passed to WPML_Elementor_Register_Strings::register_strings_for_modules() must be of the type array, null given, called in /home/twicecrn/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders/src/st/compatibility/class-wpml-page-builders-register-strings.php on line 57 and defined in /home/twicecrn/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders-elementor/src/class-wpml-elementor-register-strings.php:12 Stack trace: #0 /home/twicecrn/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders/src/st/compatibility/class-wpml-page-builders-register-strings.php(57): WPML_Elementor_Register_Strings->register_strings_for_modules(NULL, Array) #1 /home/twicecrn/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders/src/st/class-page-builder-integration.php(61): WPML_Page_Builders_Register_Strings->register_strings(Object(WP_Post), Array) #2 /home/twicecrn/public_html/w in /home/twicecrn/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/wpml/page-builders-elementor/src/class-wpml-elementor-register-strings.php on line 12

July 5, 2019 at 9:35 am #4149713

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I am debugging the issue further, in the meantime, can you check if the suggestion provided here helps? https://wpml.org/forums/topic/catchable-fatal-error-showing-under-the-translation-basket/#post-3089376

Look forward to your reply.

Thanks

July 5, 2019 at 10:13 am #4150127

rickardR-2

My issue is resolved now. Thank you!