Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 3 voices.

Last updated by pimS-4 2 years, 9 months ago.

Assigned support staff: Andrey.

Author Posts
November 24, 2017 at 8:33 am #1440116

andreyO

Hi!

yesterday I've installed the latest versions of WPML component (see screenshot).
I followed the instructions to translate content, using https://wpml.org/documentation/translating-your-contents/page-builders/, but I don't see Visual Composer content at all, which has to be translated (see screenshot). I've read, that WPML doesn't use local wpml_config.xml for Visual Composer any more, but even if I tried to create local configuration file, it didn't help

BR,
Andrey

November 25, 2017 at 12:55 pm #1441218

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

Hello Andrey,

First of all, you need to make sure that all WPML components installed have the latest official release. I noticed that WPML Media is coming from the beta package. Mixing the versions may lead to unpredictable consequences.
https://wpml.org/account/

After, try to Plugin >> Add New > Commercial and click on Check Update. After, modify a bit the original page (also try to add some element at the end of the original content if just small modifying doesn't make an affect) and save. Then, go to the translation, the content should appear correctly.

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us:
http://wpml.org/faq/provide-debug-information-faster-support/

Let me know how it goes.

November 25, 2017 at 10:59 pm #1441461

andreyO

Hello Andrey!

Thank you for your support! I have no idea, why WPML Media beta version was installed, since I installed all WPML components from Plugin >Add New > Commercial.

Anyway, after deleting of WPML Media plugin AND (!) changing all pages in a bulk action (just set again status to published) resolved the problem. I can see now all the Visual Composer text components, which has to be translated!

Спасибо за помощь!
Andrey

November 27, 2017 at 8:05 am #1441955

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

Рад слышать, что все работает. Хорошей недели!

December 11, 2017 at 3:23 pm #1454489

pimS-4

Hi,

I have the same thing. But... My main language is Dutch and i want to translate to German and English. When i make the German translation i see the visual composer content, but with the Eglish translation i dont see the content...

Hope to hear from you!