This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.24 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by Andrea Woerrlein 1 month, 4 weeks ago.

Assigned support staff: Radu.

Author Posts
August 14, 2019 at 9:05 pm

Andrea Woerrlein

I am trying to:
Access the page or post in the back-end to edit it. The Divi builder is not showing. It worked before, it stopped to work after some post is tried to created today. I disabled the WPML Translation Management plugin and the Divi builder re-appeared.

Link to a page where the issue can be seen: It is same on all pages, posts...
hidden link

I expected to see:
However I'd like to use WPML Translation Management as well.

Instead, I got:
Also, i don't see options for switching the pages and posts in 2nd language in the list: hidden link
Another thing is that I can't link 2 pages with different languages.

August 15, 2019 at 12:24 pm #4400761

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Andrea,

Thank you for reaching out the WPML support!

Do you remember making any change lately (like installing a new plugin, for example)? Also, can you deactivate all the modules of the Autoptimize plugin, and the plugin too, please? This one might be doing some changes on the scripts side which can make some pieces of code no longer work as expected. Please do this change and tell me if there's any difference.

Thanks,
Radu

August 15, 2019 at 7:59 pm #4403233

Andrea Woerrlein

Hi Radu,
thanks for reply.
No new plugins have been added before that issue occurred. Only translation to German for new blog post has been written and after hitting update button this happened.
I see that you enabled back WPML Translation Management plugin, but now I don't have Divi builder anymore. (Divi builder was there when WPML TM was disabled).
Autooptimize don't have anything with that, enabled or disabled, it is the same.

August 16, 2019 at 1:00 pm #4406431

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Andrea,

Can you tell me if you recently moved your website to https, please? I'm asking this because I can see that there are a lot of errors in the console from WPML saying that the plus icons couldn't be loaded due to some bad requests over HTTPS (please see the attached screenshot).

This might be the reason why the Divi builder is not working either. I checked a couple other websites using Divi and they worked very well. I'm pretty sure that once we manage to sort these https errors, things will go back to normal.

Thanks,
Radu

August 19, 2019 at 8:33 am #4414647

Andrea Woerrlein

Hi Radu,
thanks for your reply.
We didn't move the site to https recently, but almost a year ago. So nothing actually changed there. Those errors were there for a long time (i didn't address them because everything was fine on the frontend), and it worked fine until then.
The only thing that i'm doing now is renewing the SSL certificate (It didn't expire yet, it will in 2 weeks or so).

August 21, 2019 at 9:19 am #4429373

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Andrea,

I checked this once again and I could see that there's a JavaScript error in the console that might be causing this issue. I looked for other customers that reported the same issue in the past and the issue was always a compatibility one between WPML Translation Management and some other 3rd party plugin.

In this case, could you deactivate all the plugins not related to WPML, activate Translation Management and the main Divi theme, please? Once you do this, just try again to translate a page and tell me how things work this time. This way we can see if this issue is caused by some compatibility between WPML and a 3rd party plugin that you're using.

Thanks,
Radu

August 22, 2019 at 9:04 am #4437711

Andrea Woerrlein

My issue is resolved now. Thank you!