This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by austinD-3 2 months, 1 week ago.

Assigned support staff: Bobby.

Author Posts
August 6, 2019 at 8:08 pm #4350275

austinD-3

I am trying to get rid of all my translations and duplicate the default language posts, but when I do, a bunch of issues arise.

First, when I delete all the posts, and remove all translations, the translation manager still seems to think there are translations available. I expected the translation manager to show all yellow x's.

Second, when I duplicate my english posts, it doesn't replace all the translations. It also doesn't create new translations for each language. Sometimes it even creates and extra post in some random languages. I don't really know how to explain it, but below are the images representing pre and post duplication.

I expected post duplication to remove the old translation and replace it with a complete duplication of the english translation.

August 7, 2019 at 12:44 am #4350937

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

On a staging environment i did the following tests and was not able to reproduce the issue

1. Added a post in default language(EN) and translated it to my secondary language(GR)

2. Went to WPML=>Translation Management dashboard and can see now that the translation has a "checkmark" next to it since it is 100% translated with different content

3. Select the post in the Translation Management Dashboard and then select to Duplicate the content from the dashboard , the original translation is overwritten with English content and the "green check mark" is now turned to the duplication image

4. Went to Posts -> select Greek translation and delete it, then go to Trash and empty the trash. This will then turn the duplication mark to the yellow "X" as the translation was removed. (You have to clear your trash for this to happen)

August 7, 2019 at 1:03 pm #4355277

austinD-3

I am doing the following:

1. Delete all pages except EN (default)
2. Clear trash
3. Cancel all translation jobs
4. Duplicate all pages in Translation Management

The result is what you see above. Any ideas what might be going on? One thought I had was that it might be a memory limit issue. Does this seem possible?

Another thing I'm noticing is that even when I use page duplication inside the correct page, it will allow me to duplicate only a handful of the languages as well. ES, for example will not translate, even if I attempt it individually.

I also notice it says I have 1 page in drafts, but when I go to display drafts, there is nothing listed.

If there's something wrong with the plugin, how could I reset it to defaults?

August 7, 2019 at 1:26 pm #4355361

austinD-3

One more note: it looks like the plugin is duplicating the posts, but not showing them in the ui.

Note that all of the languages have one post (after running post duplication), but WPML seems to think that only some of them have duplicate posts.

August 7, 2019 at 6:12 pm #4357293

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

As i am not able to reproduce this behavior on my environment i would like to take a closer look if possible as there could be some fields missing from your database or a 3rd party interference

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

August 7, 2019 at 6:32 pm #4357387

austinD-3

I am still having issues with this problem, but cannot give you ftp or admin access.

The only remaining issue is that when I duplicate posts, they seem to be orphaned. They aren't registering as translations of my main content.

When I try to fix the using the button (Assign translation status to duplicated posts) on the troubleshooting page, I get an error;

August 7, 2019 at 7:27 pm #4357689

austinD-3

Is it possible to do a screenshare to show you what's going on?

August 7, 2019 at 8:02 pm #4358027

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

if i understand correct, you perform the duplication for example on the Front Page and instead of the "+" sign turning to "pencil" icon it remains but then under each language you see the translation, correct ?

When you get the error you shared above with me , i am guessing its in the console log ?

Please try the following

1. Create a test page or use the other page that is not duplicated , edit the page and select 3 languages to duplicate to instead of all at the same time.

let me know your results

I want to exclude the possibility of this being caused due to the size of languages activated

i have seen a similar issue when too many languages were activated on a server without enough WP MEMORY LIMIT (yours seems ok though as i can see its set to 512M )

2. Please provide me with an error log

You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
define('WP_DEBUG', true);

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');

This will create an error_log.txt file in your site's root directory. Please send me its contents.

3. I understand that it is difficult to gain access to the backend , in case you need my IP its this one : 45.48.70.119

but also we can try using a duplicator package which you can create using the duplicator plugin (filter out media and uploads folder if possible) and then share with me a link to the package to test locally or we can even migrate the dev site to our cloudways server, you can perform the migration from your side

August 7, 2019 at 9:33 pm #4358383

austinD-3

I'm working on getting you admin access and whitelisted.

Can you send me another secure credential form?

August 8, 2019 at 9:06 pm #4366067

austinD-3

So I tried the advice above.

1. The 3 language pages duplicated the same way as before. All were created, but none were recognized as translations.

2. Error logs are not being generated for some reason. Here are my config.php definitions:

define( 'WP_ALLOW_MULTISITE', true );
define( 'MULTISITE', true );
define( 'SUBDOMAIN_INSTALL', false );
$base = '/';
define( 'DOMAIN_CURRENT_SITE', '' );
define( 'PATH_CURRENT_SITE', '/' );
define( 'SITE_ID_CURRENT_SITE', 1 );
define( 'BLOG_ID_CURRENT_SITE', 1 );

define( 'WP_DEBUG', 'true' );
define( 'WP_DEBUG_LOG', 'true' );
define( 'WP_DEBUG_DISPLAY', 'false' );
@ini_set('display_errors',0);
ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');

August 9, 2019 at 3:54 am #4367249

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

There is a possibility some fields are missing from your WPML database tables

this is not a known issue at the moment therefore without being able to take a closer look at the database or the site i am limited on suggestions

if possible please see if you can create a duplicator package and share it with me , i have enabled the private field reply, there is no need for the backend access if i have the duplicator package

August 9, 2019 at 3:46 pm #4371723

austinD-3

Please allow me to send you my login credentials.

Standard duplicator plugin does not work with multisite.

August 9, 2019 at 8:13 pm #4372857

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

No problem !

private reply has been enabled

thank you

August 10, 2019 at 3:37 am #4374581

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details !

i have created a test page called WPML Test and i was able to duplicate it over to all the languages as expected, can you please confirm

therefore it seems that the front page and characters pages are the ones with trouble correct ?

i also created another 2 pages and assigned to them the "characters" and "front page" template and it worked as well.

August 12, 2019 at 4:46 pm #4382483

austinD-3

Ok, so how would you recommend I fix the current posts? I see that it's working for new ones, but I'd like to save the old ones, or copy their data to a new one if possible.

Is there some way to copy the content over to a new post without having to repopulate all my fields? (There is a lot of content in these 2 posts)