This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 8 replies, has 6 voices.

Last updated by karthikB 3 weeks, 4 days ago.

Assigned support staff: Bruno Kos.

Author Posts
January 10, 2019 at 10:15 am #3075298

Irene

When using the Gutenberg editor I get this warning

"The block editor requires JavaScript. Please enable JavaScript in your browser settings, or try the Classic Editor plugin."

This warning will disappear if I disable the WPML Multilingual CMS plugin, the warning disappears. So WPML is clearly the culprit.

You need to to fix this ASAP.

January 10, 2019 at 10:24 am #3075315

Irene

The same issue happens with 2 more sites. It did occur with the update from WP 5.0.2. to 5.0.3.

January 10, 2019 at 10:29 am #3075342

encodia

The same happens here. No console error.

January 10, 2019 at 10:51 am #3075409

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Thank you for contacting WPML support!

WPML developers team is aware of this issue and has already worked on this. It will be fixed in next release, I can't tell you the exact date, but most likely very soon. Please note that this isn't affecting Gutenberg or WPML functionality so you can resume your work and ignore the message.

Regards,
Bruno Kos

January 10, 2019 at 11:17 am #3075534

Irene

Thanks for the update. I suggest to add this to the known issues section.

January 10, 2019 at 11:54 am #3075787

Amit
Supporter

The fix for that is ready and being tested, the release will be out probably after the weekend.

February 28, 2019 at 10:43 am #3254663

artemC

Yesterday I got this same issue:
just let me to add my details: (please note English is not my native language)

When you activate the plugin "WPML Multilingual CMS" (Version 4.1.3) We see, that swears Gutenberg:
"The block editor requires JavaScript. Please enable JavaScript in your browser settings, or try the Classic Editor plugin."
All the latest versions (or almost so) on 27 Feb 2019 (WordPress 5.0.3).
The message appears as when creating a new one and when editing an existing page.

Sreen: hidden link
Screen with debugger: hidden link

February 28, 2019 at 10:48 am #3254691

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi @artemc, please see our current WPML version:

https://wpml.org/download/wpml-multilingual-cms/?section=changelog

March 13, 2019 at 10:54 am #3332273

karthikB

Hi,

We are facing the block editor issue in WordPress Gutenberg editor when using the WPML String Translation plugin. We have mentioned the error which we are facing in our website and some javascript conflicts also occur when editing the page.

We got this error message when adding the blog in Gutenberg editor.

" This Block has encountered an error and cannot be previewed "

Currently, we are using a WordPress version 5.1.1

WPML Multilingual CMS - 4.2.4.1 Version
WPML String Translation - 2.10.2 Version
WPML Media - 2.5.1 Version
WPML Translation Management - 2.8.3 Version

We have attached the screenshot for your Reference. Please find the attachment.